0

My tablet won't turn on and Android won't start up on it. As usual I charged it last night, and it charged to 100%.

But now it is not turning on I have tried a lot of times to turn it on by pushing the power button but it is not turning on. What should I do? I have tried many many times to push the power button it pushes but nothing happens. The company that made my tablet is a Chinese company, Ampe.

  • See if it has a "hardware button reset shortcut" to force a restart. On my Google Nexus I can long press all 3 buttons simultaneously to force a reboot. – ce4 Jun 14 '13 at 9:25
  • @ce4 I think usually just long pressing the power button only will force a reboot, or at least it does on my Nexus 7. – Peanut Jun 14 '13 at 9:41
  • 1
    Not sure if that helps, but I'd try removing the battery for a couple of seconds (make that a minute to be on the safe side), then re-insert it, and try again to power it up by pressing the power button. That's at least as good as a reboot #) – Izzy Jun 14 '13 at 12:16
  • I would also have recommended that but tablets usually have non-removable batteries... – ce4 Jun 14 '13 at 20:27
  • @ce4 But they have reset-holes which can be used to accomplish the same :) – Izzy Jan 20 '14 at 20:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.