So, I got myself s4 and rooted it. I've tested the root access with several different apps, and all of those work.

But now I tried Network Spoofer. The app seemed to download and install successfully, but now, when I try to actually do something, I get this:

chroot: can't execute 'spoof': Permission denied
Screenshot: chroot: can't execute 'spoof': Permission denied (click image for larger variant)

How do I fix this?

1 Answer 1


The app's homepage at http://digitalsquid.co.uk/netspoof/ lists the requirements needed for the app to work:


Network Spoofer runs on Android devices with the following requirements:

  • Which are rooted (‘su’).
  • Have an SD card (or internal storage) with >450MB spare space.
  • Which has Wifi

So I'd start by double-checking how much free space you have on your device. Then it lists the currently supported (and unsupported) models:

Supported devices

Currently Network Spoofer has been thoroughly tested on these devices:

  • Samsung Galaxy Nexus
  • HTC Nexus One
  • T-Mobile G1

It is reported working on these devices, as well as working on most other devices:

  • LG Optimus 2x
  • Huawei u8150d
  • HTC Hero
  • Droid Bionic
  • Samsung Galaxy S / S II
  • Samsung Infuse 4G

However, Network Spoofer doesn’t currently work with:

  • Droid / Droid 2 / Droid X
  • Motorola Atrix

Many other devices should and probably will work, but please report any odd behaviour or crashes, so I can get this working with more devices.

Your device unfortunately isn't on the list of currently supported devices, which means that the app's author doesn't guarantee that it will work for you.

If you follow the bug reporting link there are ways there for you to provide the dev with more information, so that they can try to get things working on your device. But before you go there, have a look at Network Spoofer's FAQ page which does list some common problems, and some ways to get round them, or what additional information you can provide to help get the problem fixed.

Finally there is currently an open bug report about Network Spoofer not working on an S4, with the same error message that you're getting, that does list how the reporter of the bug got it to work:

I had the same problem when trying to run bt5 on my phone using the Complete Linux Installer app, but solved the problem by changing the script from the file bootscript.sh (attached) to the combination of the 4 other files (installbt first, then startbt, and bt, then stopbt to unmount everything). The chroot command is located in the bt script.

That could be worth trying (you'll need to visit the bug report to see the attached files).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .