3

I recently got an Asus Nexus 7 Tablet shipped to me, and want to be able to use all of the .apk files I have saved on my computer (all purchased/downloaded legitimately). Here's the issue:

I'm in the navy and underway, and will be for quite some time. I have no ability to connect my Nexus to a wifi/wired network (not allowed to plug it into a ship's network computer via USB), and I have no ability to connect my personal computer to the internet either, so setting up a Google Play account on the tablet is a no-go. My laptop is a Macbook, and I DO have Android File Transfer installed, but that's pretty much all I'm working with here.

When I plug my tablet into the laptop, Android File Transfer pops up, and I can drag and drop files onto the Nexus, HOWEVER, I don't have any file manager program to access the .apk files once they're on the tablet.

I have tried going to settings and checking the Unknown Sources box in the Security menu, dragged and dropped an assortment of .apk files into the Nexus root folder, and then have entered "file:///sdcard/xxx.apk" into the Google Chrome internet browser window ("xxx.apk" being whatever file path I'm trying to access). But when I hit "Go", the browser page just flashes, refreshes with a blank address bar, and it's like nothing happened.

Is there any hope for me, or is this Nexus 7 just going to be a very expensive paper weight until I finally see land (and wifi) again?

Thanks in advance for any advice!

2

The first thing worth noting that your original attempt at pointing your browser to the .apk directly should work (see the comments starting with Stephen Schrauger's). It's not really clear why this would not be the case for you, but you may want to double-check your Downloads app (in the app drawer) and your pathing. It could be that it's "downloading" in the background but it happens so quickly that you do not realize it.

If for some reason that really isn't working, then you can try a potential workaround. This is pretty ugly, but it does work. I've tested this on my Nexus 10, for reference.

Create a folder on your laptop that contains your apk files (we'll call it apkfolder for the purposes of this example), then within that folder create an HTML file (we'll call it apkinstall.html) using a text editor. Since you have an Astro apk, use this as the content of the HTML file:

<a href="Astro.apk">Install Astro</a>

Where Astro.apk should be the actual name of your Astro apk file.

Now copy apkfolder onto the root of your Nexus 7's storage using Android File Transfer. Make sure that all the apks copy over as well as the HTML file.

If you are using TextEdit on a Mac: TextEdit will attempt to treat things as RTF files by default, so even if you save it with a .html extension it may not work. One workaround I've found is to go to Format > Make Plain Text before you save the file. You'll know you're in the correct format when the rulers and such disappear from the TextEdit window. Then you can save the file and make sure you use change the .txt to .html.

Next launch your browser, and point it to file:///sdcard/apkfolder/apkinstall.html. You should get a mostly blank page, with a link that says "Install Astro". Click that link to install the Astro apk from your storage, then use Astro to install all your other apps. If you're using Chrome, then you'll probably need to pull down the notification bar and tap the "Download complete" notification to actually kick off the install.

In the more general case, if you didn't have a file manager apk, you could instead add a bunch of link entries to the HTML file - one for each app - and install all of them that way. In your case, this shouldn't be necessary.

  • I am html illiterate, so I'm not sure if I did something wrong, but there is no link, just the exact text from the html document: <a href="Astro.apk">Install Astro</a> – mbamb19s Jun 18 '13 at 16:37
  • 1
    @mbamb19s: So Chrome displays the plaintext when you open the file? Is it saved with a .html extension? Make sure it didn't end up with two extensions (e.g. apkinstall.html.txt or something). Some text editors will do that do you. – eldarerathis Jun 18 '13 at 16:40
  • @mbamb19s: if you're using TextEdit on your Mac, see my edit. It appears to save the file in the wrong format by default. It may be easiest to delete the file and recreate it with the same content (the text you typed in looks exactly correct). – eldarerathis Jun 18 '13 at 16:52
  • I've tried retyping it, making a new .html file, and still it doesn't show up as a hyperlink... very odd. I've made sure that it is saving as a .html as well, so I'm not sure what the issue could be. – mbamb19s Jun 18 '13 at 17:11
  • 1
    @mbamb19s: Maybe the best thing to try is a full factory reset. Since you don't seem to have anything useful on it yet, there wouldn't be any downside. Then retry the solutions provided and see what happens. – Stephen Schrauger Jun 18 '13 at 18:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.