7

I have a Samsung Galaxy S3 with untouched Android 4.1.2 and problems with logging into accounts on any website, in any browser, as long as the password contains an exclamation mark ("!").

I use the default Samsung keyboard for typing in the password. The language of the keyboard is set to German. The Android interface language is set to English. I use the exclamation mark which is seen on the first of three special character pages.

I tried this in the Chrome browser app and in the default "Internet" browser which comes preinstalled. If I change that exclamation mark in the accounts password to something else, I can login flawlessy on my smartphone.

Is this a codepage error? Do I have to set up some special localization or is it just a bug?

  • 7
    What if you copy-paste an exclamation mark from any website instead of typing it on the Samsung default keyboard? Do you have any means to record what's being sent (e.g., maybe a space gets inserted after an exclamation mark automatically, etc.). Or use Google's native keyboard app (or here) – ce4 Jun 20 '13 at 9:07
  • I agree with ce4 an inserted space being the most likely cause. It's for sure no codepage thing, as the character is part of US7ASCII, which is contained in all encodings in the same place. So you could either try different keyboards, or simply avoid exclamation marks in passwords :) – Izzy Jun 20 '13 at 9:16
  • Have you checked which char is sent to the server instead of the exclamation mark? Enter "!" at base64encode.org and look at the base64 encoded result. If it is correct "IQ==" should be the result. – Robert Jun 20 '13 at 15:10
  • @Robert: It is IQ==, so no errors here. – Ray Jun 20 '13 at 16:08
  • 2
    @ce4: Wow, thank you! You were right! A space is inserted mostly unnoticably. Wow... I think they have to overthink their auto-complete stuffs in password boxes. If you write this as an answer, I will check it. – Ray Jun 20 '13 at 16:09
8

In the comments, ce4 pointed out what was going wrong.

A space gets inserted automatically after each exclamation mark (and probably other sentence limiting characters like full stop, half stop or question mark too), resulting in an invalid password with a space char too much.

Whenever I enter an exclamation mark, I also enter the following character, use backspace twice and then enter the following character again. Seems to be the simplest solution yet.

Samsung should consider turning off these weird auto-complete stuffs in password boxes!

2

I have also encountered this "bug" but with a $ character. Whenever I typed $ it automatically inserted spaces before and after the $ character. My solution was to turn off "automatic spacing" on the Samsung keyboard settings and this worked for me ever since.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.