I want to install ArchiLinux on my multipad. I have tried to root my Prestigio MultiPad (model: PMP3670B) using some rooting apps I had found on the Internet, but all of them have requested an adb driver, which I have problems installing on my XP because it won't autodetect the device. As mentioned in all the instructions I had set my device to USB Debugging Mode and to MTP Mode.

I downloaded SDK and, using a couple of instructions, including some on modifying android_winusb.inf and adb_usb.inf, several times tried to install it manually. The Device Manager displayed MultiPad as two devices (MTP and Android), that had an icon with a yellow question mark. The best I could achieve was making the Add Hardware Wizard detect the MTP (it still wont detect the Android).

Using The command prompt I opened platform tools folder and executed adb kill-server, adb start-server and adb device commands, but the "List of devices attached" was empty.

Also when I tried unchecking the USB Debugging Mode on the Multipad and my XP started displaying it as a Portable Media Player.

This is my first tabled, so I'm really inexperienced. I guess I'm making a mistake somewhere, but I can't figure out where.

Maybe someone has rooted this or similar Prestigio MultiPad on XP and could help me?

  • 2
    If the drivers don't work, you might want to take a look at the Universal ADB driver and see if that works out. – Izzy Jun 24 '13 at 13:04
  • Thanks a lot! It is now displayed in the "List of devices attached", but I'm still unable to root the tablet. Neither the Command Prompt "adb root" command , neither the third party apps(start oneclick root) allow to root the device. Maybe you know another app, that could root it? – Marguerite Navie Jun 27 '13 at 10:04
  • adb root doesn't root your device -- it just switches to root mode if it already has been rooted. As for available methods: Have you checked the rooting tag-wiki, and followed it up to our rooting index? I've just added your question there (we permit one "how-to-root question" per device, and link them there), but at the end of the devices list comes a list of known methods which you could try. – Izzy Jun 27 '13 at 11:22

Here's how to do root Prestigio MultiPad PMP3670B: -download application "Motochopper" , after extracted, just run the file "run.bat" -I think you know the rest: to have installed the USB drivers to have enable "usb debugging" etc.. :)) I searched for two weeks, every day, after I found a forum Rusia.Daca.

Simple way is just do it from your computer. Yes I did it. Do not follow stupid internet long discussions and links loaded with catches and adverts and prerequisites..

King root is free and does the job. Use the PC version it is available on official king root website. Just follow instructions..initially when root succeed it will not show with root checker but reboot and it will show.

  • If your method worked for OPs device, mention that to improve value of your answer – beeshyams Jun 24 '16 at 8:46

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.