3

I am trying to figure out why my apps don't work on tablets manufactured by the company Ainol.

USB debugging is already turned on, and I took a look at all of the settings that I could find on it, but the USB debugging bridge refuses to find it.

I figured out that it might be because the tablet ALWAYS connects the USB file transfer (either as mass storage, or media, or camera, but it ALWAYS connects, and I found no option to not connect).

How can I force ADB to find it somehow?

0

Normally you should have to install the driver of the tablet to have ADB working with it. On the opposite, mass storage usually work out-of-the-box because any PC recognize this standard.

After some search on Google I found some info that may work with your tablet here: http://www.slatedroid.com/topic/70585-adb-drivers/page_p_805857

  • I am on OSX! How drivers are installed on it? – speeder Jun 24 '13 at 15:42
  • I have been using Android SDK on Ubuntu a lot and there was no driver but a rule needed to be added in /etc/udev/rules.d like explained in developer.android.com/tools/device.html. However according to the same page Mac OS should work out-of-the-box. – jmbouffard Jun 24 '13 at 16:31
0

I gather you are under OSX so no need for driver or udev rules but there is some points you need to make sure you follow .

  1. Make sure your device is unlocked when connected to PC.
  2. Make sure you have accepted the pop-up message on your tablet allowing your PC to debug it.
  3. Make sure your usb cable is working perfectly.
  4. The usb storage ot mtp mode doesn't matter.
  5. If you are still struggling and couldn't make it work via usb try making it work via network.
0

You don't need to force USB debugging to be able to use it. But if that is your biggest concern, there are some two files you may need to take it if you access the superuser privileges. These are "/system/build.prop" and "/default.prop". Here are the lines of code to look for in build.prop and default.prop to modify them to exactly how I have written them here or else create then:

persist.service.adb.enable=1 persist.service.debuggable=1 persist.sys.usb.config=mtp,adb

Or if you have a custom recovery like twrp you can access terminal and run these commands:

adb shell su
mount -o remount,rw /system cd /
echo "persist.service.adb.enable=1
echo "persist.service.debuggable=1
echo "persist.sys.usb.config=mtp,adb

Once you reboot into Android you should be able to see ADB persisted always.

-1

Download PDANet from Google Play and for Windows in your PC. After doing a few configurations your PC should be able to detect your device.

  • 3
    Welcome to Android Enthusiasts! This post does not contain enough information to be considered an answer. How did it solve the issue? Where to find it? What are the steps to perform? Please use proper English to the best of your ability. Consider following this guide: How do I write a good answer – Tamoghna Chowdhury Dec 2 '15 at 7:08
-1

Go to settings and visit developer options (if it's not there see the end of my answer). Then enable developer options and enable USB debugging.

Enabling developer: Go to settings=>about=>software info=>and tap build number a bunch of times very quickly.

  • 2
    -1: "USB debugging is already turned on" – Andy Yan Feb 28 '17 at 4:35
  • Check if it works and if it doesn't I will delete my answer. – gkeeg Feb 28 '17 at 4:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.