1

my question is aimed to those who have already performed some kind of network traffic analysis on Android.

My device is a rooted Nexus One. I've developed a simple C program, using Pcap Libraries, which sniffs packets over its eth0. Then I have a simple Python script, using Scapy, which sends to my device self-made packets (with raw payload of 1000 characters).

What I want to analize is the decay of my device ability to sniff traffic packets out of the packet rate increase. What I expect is that the lower is the packet rate, the more packets my device is able to capture.

What I get is something inconsistent:

Pck/s|Tot_sniffed
100           179
1090            0
2080          161
3070          968
4060          628
5050          562
6040          698
7030          546
8020          391
9010            0

I send 1000 packets with left column rates (packets per second). That's very strange imho and I can't get what's happening.

I already have:

  • Checked RAM and CPU usage (they're both under control, CPU doesn't exceed 23-24%)
  • Checked Wi-Fi connection (it doesn't turn off)
  • Killed / Suspended / Uninstalled every other application not needed from Android system
  • Tried to change parameters and packet size but it's always the same.

I'm trying to look for any known report about Nexus One unstable behavior. But I'm not really sure it depends on my device.

Have you any good idea about what's happening and how can it be possible? Thank you in advance!

EDIT: I've done more tests to reply to @Peanut. I've also changed my Wi-Fi network, placing notebook and Android device close to the router.

The usage is this:

Usage: python  Main.py < targetIP >  < port >  < numPackets >  < packetSize >  < initial speed >  < final speed >  < step >

Results.

I really can't figure out what's going on.

  • How many times did you run the tests? It seems odd you don't get any packets at all for 1090. It could also depend on the quality of your WiFi network. – Peanut Jun 24 '13 at 15:59
  • @Peanut edited my OP with more tests – Rob013 Jun 25 '13 at 18:33
1

After some days of struggling I've come to the understanding that my Nexus One's NIC was corrupted/broken/something_bad_else. My tests were all messed up and with no logical connection.

I've tried with a S II device and results seem to be a little more consistent. By the way, even in this case, I can't achieve a worse throughput increasing the bit rate, actually it's still floating around 90% (from 88 to 95 randomly).

Probably it is dued to wi-fi instability and UDP packets instead of TCP. For my purpose having tried with a different device gave me a suitable answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.