0

As seen below, anything to do with Google Play is installed in the Android SDK in my Ubuntu.

enter image description here

In light of this SDK Extras set above which has the Licensing Library, it is perfectly legal to have Google Play in emulators created here (correct me if I am wrong). Google Play is a factory default. Yet, when an emulator instance is created (even for that matter, a Nexus with Google API (say 10)) Google Play isn't already there.

So, in an attempt to install Google Play the closest I got is using this guide, as per which, I downloaded gapps-jb-20130307-signed.zip (the ZIP file for Gingerbread 2.3.3) and unzipped it and just executed the adb commands in the script given at the very end.

What I ended up installing was the Android Market! Why?

  • 2
    Minor correction: it's not the ZIP for Gingerbread, but JellyBean -- as pointed out by the -jb- part in the file name. So its even more strange it should contain "Android Market" instead of "Google Play". – Izzy Jun 27 '13 at 8:54
  • I downloaded the zip with -gb- in place of -jb-. Installed Google Repositories (screenshot above), once again to no avail. – Karthik C Jun 27 '13 at 10:19
  • 1
    On GB, it might still contain the "Market" app. But don't worry, it should automatically update itself to "Playstore" once you've configured your Google account and used it at least once. – Izzy Jun 27 '13 at 11:24
  • Updates itself! Wow! I don't need to uninstall it then. Will wait and see. Thanks! – Karthik C Jun 27 '13 at 11:26
  • 1
    That's what it's supposed to do, yeah :) Give it a few days (usually, it doesn't take that long -- just start the "Market" app and browse a little, then exit it, have a drink, and when you try next it's called "Google Play"). Once it solved, feel free to answer your own question -- or add a comment if you prefer me doing so :) – Izzy Jun 27 '13 at 11:33
2

I browsed a bit on Android Market and then I pushed another file from the zip downloaded. It's named MarketUpdater.apk. That's what updates the Market to Play Store!

Tried starting from scratch and pushed market updater too! So it was Play Store right when it sat in.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.