2

I'm Running a Galaxy S2, with the AOKP milestone rom (JellyBean). Occasionally, the screen will turn on by itself (even when no user apps run in the background) after being turned off, light up, turn off and on again, it won't remained off for a long period of time. Needless to say it's annoying and battery draining.

Rebooting doesn't always help, some times it goes away only to return a day or 2 later. Has anyone else encountered this issue with AOKP or other CyanogenMod based roms, and if so how you did addressed this? how should I fix this or disable this?

  • My GF's Galaxy Nexus was having the same problem, though it had the additional problem that it didn't want to charge. I did a factory reset (after trying various settings), which seems to have solved the problem for now. However, I'm not sure if its exactly the same problem. – Ivo Flipse Jun 27 '13 at 8:07
  • I did a factory reset before flashing, doubt another one will help, I just don't want to go through the mess of backing and restoring only to have this happen again. EDIT: also as far as I know, it may also be a fluke with the device mishandling things – svarog Jun 27 '13 at 8:09
  • 2
    But you installed a bunch of stuff after flashing right? Can't those things and/or any setting changes be responsible? – Ivo Flipse Jun 27 '13 at 8:25
  • 1
    Something might run a service in background which, from time to time, requests a full wakelock. That would force the screen on for the time the wakelock is held. You could use BetterBatteryStats or Wakelock Detector to find out if that's the case -- which might even reveal the culprit then. – Izzy Jun 27 '13 at 8:45
  • Wakelock Detector marked the facebook app as one source, uninstalled it and the wakelocks still continue (the googlesphere also pointed that other users also had wakelocks from the FB app!!), either it didn't work or there is another source. – svarog Jun 27 '13 at 9:17
1

I eventually found the cause of the issue to be in the screen-off animations in the display settings. I had the 'Electron Beam' animation selected, I disabled the screen off animation and the wake-locks stopped.

  • Its the small things!! +1 for figuring it out – HasH_BrowN Feb 25 '15 at 15:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.