4

A friend has a factory fresh, unrooted Samsung Galaxy S Duos, and except for Whatsapp every other internet accessing app works fine on a 3G or EDGE connection.

She has un/reinstalled Whatsapp several times. It works fine over Wifi. She's no power user, so any solution involving rooting the phone is not an option.

To clarify - there is nothing wrong with 3G or EDGE on her phone, since she can browse the internet and use other such apps perfectly fine.

Update - She's on Vodafone, as I and thousands of people in India are, and no, Vodafone is not blocking Whatsapp for any reason.

Searching for solutions on Google only leads to 'No shit, Sherlock!' type answers with genius level solutions like 'check whether your 3G connection is working' or 'get the latest version of Whatsapp'.

So is there a workaround?

  • The Duos is multi-SIM, and WhatsApp is known to have issues with that. Are you certain WhatsApp is using the primary number/data connection? – Andrew Lott Jun 27 '13 at 11:20
  • My friend has only one SIM, and she was using Whatsapp on her older phone with that one. Does the DUOS designate a particular slot as primary or secondary? – Rex Jun 27 '13 at 12:43
  • Or maybe the operator has blocked it. – roxan Jun 28 '13 at 18:15
  • I have the same operator, and it worked fine on her old phone. – Rex Jun 29 '13 at 19:03
  • Are you using only one or two SIM cards? In which slot do you test it? – kokbira Jul 3 '13 at 15:32
4

i also had the same issue. Incase you are on vodafone network, try and select vodafone gprs as ur default settings.

It worked for me the same way.

Hope this suggestion helps

  • I have been off the site for months - tried this again with another friend and it absolutely worked! :) – Rex Oct 23 '13 at 8:53
5

I faced similar problem until recently I found the fix. I use Vodafone 3G Pack.

  • If you are an android user, check the network and settings -> Access Point names
  • In that check if APN is set to Vodafone Live.
  • If yes, change it to default settings and it should be changed to vodafone Mobile connect.
  • Also, then check the value of MCC and MNC. It should be as per country code and mobile operator.

I didnt understand, why this changed on its own, but after making this change and rebooting phone, it worked for me.

I hope this works for you too..

0

Good morning..Here are the solution-options for your mobile, if "What'sApp" NOT working on mobile-data pack.enter image description here

  • 1
    The last part is somewhat carrier-specific. OP already claims he's using Vodafone. – Andy Yan Aug 17 '16 at 9:51
  • Plus I already marked this question as answered 3 years ago :\ – Rex Aug 25 '16 at 6:19
-1

I had a similar problem. Reset the APN settings to their defaults and it will start working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.