I recently installed PdaNet+. To use wifi tethering it asked my to accept a certificate and set a screen lock pattern. I have since uninstalled it and removed the FoxFi certificate, but I still can't disable the screen lock (which I don't really want).

Any suggestions?

10 Answers 10


I just had that same issue today.

Go to Settings, and make sure you've removed Foxfi as an administrator. Go to Trusted credentials > User > and remove Foxfi. Then go back into Settings > Security > and Clear credentials. It'll let you change the lock code then! :)

| improve this answer | |
  • 2
    It worked, but in my device : 5.1.1 it's located in Settings > Security > Certificate management -> Clear credentials – Ronen Festinger Apr 5 '16 at 15:44
  • Clear credentials should work. If it doesn't kick in then try rebooting the device. Worked on a Huawei P9. – zamber Jan 3 '17 at 12:16

Same thing happened to me.

All you have to do is go to "security" then go all the way down to "credential storage" then clear all credentials. Than you can go back and it's all done.

| improve this answer | |
  • Go to Settings --> Security --> Scroll to Credential Storage section --> Choose Clear credentials. – Saif Jul 5 '17 at 7:15

There is a simple solution to this one. First of all change password lock to pattern lock. Then enter wrong pattern 5 times. You will see forgot password. Click that and enter account details. Then a screen will appear saying to change the lock type. Simply hit the back button and it will be automatically set to none.

| improve this answer | |
  • Lol. I can't believe that this worked. Thanks – Niklas R Jan 13 '15 at 13:55

This turned out to be a red herring for me. I just had to enter my password one last time to get rid of the lock screen. I hadn't pushed on an unlocked door.

so go to Settings->Security->Lock Screen Enter Password

| improve this answer | |
  • 1
    Thanks, this answer turned out to be the correct solution for me, I didn't understand what I had to do until I saw your answers. – KoKo Jul 19 '14 at 3:47

Go to settings and go to more, which is below data usage option. Then go to VPN and delete all vpns (jus clear it all). It is that which is blocking that screen lock setting.

| improve this answer | |

You should be able to turn off the lock screen security somewhere in Settings>Security>Screen Lock and then change it to none or just a simple slide to unlock or whatever you want. This is how you get to it on my S3, but yours should be similar no matter what phone you have.

To fix your other issue, also in the Security tab on my phone, there should be a tab called "Device Administrators." When you go into this tab, it allows you to check and uncheck which apps have access. If you uncheck the app that is preventing you from changing this, it might solve your problem.

| improve this answer | |
  • In the security screen, the "None" option is greyed out, with the text "Disabled by administrator, encryption policy, or credential storage." Same with the slide option. – user36664 Jun 27 '13 at 18:53
  • Can you at least pick something like a slide to unlock or anything other than the pattern? – VarnerBeast14 Jun 27 '13 at 18:55
  • No, see above edit. – user36664 Jun 27 '13 at 18:56
  • Are you not the administrator on the device? Check my updated answer. – VarnerBeast14 Jun 27 '13 at 18:58
  • The only thing in device administrators is Motorola Device Policy which is deactivated. – user36664 Jun 27 '13 at 19:06

There is indeed a way to remove the lock screen while keeping the certificate: set a pattern lock and try to unlock the phone with a "bad pattern" for 5-10 times, it will show you an error message, now select "Forgot Pattern?" and enter your gmail/password. After these steps the screen lock will be removed without removing the certificate. "

| improve this answer | |
  • This works. Though, "none" option was still disabled until i tried @Merisol's answer – IsmailS Jul 27 '15 at 17:53

disable by administrator encryption policy, or credential storage

if you are using Androidlost.com

  1. go to andoridlost.com
  2. Sign in with your device gmail account
  3. click on Security option
  4. lock phone option - clear all number & other
  5. Unlock phone
| improve this answer | |
  • Why would you think the questioner is using AndroidLost.com? They already said the problem is PdaNet+/FoxFi. – Dan Hulme Oct 13 '14 at 13:16

You need to check if you've installed any 3rd party Device Management Applications, like Kaspersky Device Security, KNOX, etc.

I just solved my issue by deleting Kaspersky and all goes well.

Try to see which applications manage your device such as "Tracking your device against thieves so you could erase it remotely".

| improve this answer | |

Settings>Security>Device administrators and you disables all administrators

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.