So I partitioned my 32gb micro sdhc card with USB cable, both partitions FAT32, the bigger one set as active, and when I start Link2sd it doesn't ask me to select the file system of the second partition in order to create a script there and use it as install location, even though it shows up in the storages in Link2sd menus... How can I make it recognize the second partition, do I have to format the sd card with card reader, because I don't have one right now

  • So what's the question? You can't just share your problems and not ask a specific question on this site. Commented Jun 27, 2013 at 20:35
  • there, edited.. Commented Jun 27, 2013 at 20:37
  • Verify init. D. Maybe not mouting on boot.
    – Carlos
    Commented Apr 23, 2017 at 12:55

3 Answers 3


According Link2SD page, also the second partition should be primary:

You should have two partitions on SD card and both should be primary. The first FAT partition is your standard SD card storage. The second partition is used for application files and can be ext2, ext3, ext4 or FAT32.

Check if the second partition (the first one can not be used to link apps) is primary and not an extended partition.

  • Yes, they are bot set to primary Commented Jun 27, 2013 at 21:18
  • Still nothing, tried to format it again, restarted phone, and still Link2sd does not ask me what file system is the second partition in order to set it as install location and then restart the phone Commented Jun 27, 2013 at 22:12
  • Is your phone rooted?
    – igi
    Commented Jun 27, 2013 at 23:11
  • yes it is, but it turned out to be something else, I'll answer Commented Jun 28, 2013 at 7:23

Apparently it was some bug in the app itself, I had to clink the options, go to More, and there select Recreate Scripts, then it asked me what file system was the second partition, restarted, and it worked just fine after it. And all of that without card reader, like they are suggesting everywhere


The second partition has to be formatted as either ext2, ext3 or ext4, if you're on a custom ROM.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .