6

I have my Verizon Wireless Samsung Galaxy S4's developer options enabled with USB debugging turned on. Whenever I connect it to my machine, it displays "Connected as Installer" in the notification window. However, after about thirty seconds, it switches to "Connected as Media Device" without me having done anything. This behavior is seen no matter which operating system I connect to (tested in OSX and Windows with appropriate drivers installed). I would like it to connect as a media device by default.

Does anyone know how to permanently keep the phone in "Connected as Media Device" mode?

  • I have sort of the opposite problem myself, though I expect the solution would be the same (to make one's chosen option stick!) Going to search some and see if I find anything... – Andrew Barber Sep 5 '13 at 16:36
  • I think I would actually rather have it connect as "Connected as Media Device" by default. – BVB Sep 5 '13 at 16:41
  • I agree there. and it seems to switch back to installer for no reason. Aggravating! – Andrew Barber Sep 5 '13 at 16:50
  • 1
    After researching this for a while, I think it may be Verizon's doing, as the "Installer" connects as a disk that has some software that one can install. Then it goes back into the regular "Media Device" mode. The only reliable way to turn it off is to root your device, which I would rather not do at this point. – BVB Sep 5 '13 at 16:58
  • I think that makes sense. I just went ahead and let it install to see how that works out. – Andrew Barber Sep 5 '13 at 17:48
3

After connecting via USB and receive the message "connecting as installer" on your phone's screen, make sure you're phone isn't on the lock-screen and swipe down from the top (or at least on my Verizon device) you can access "USB PC connection" settings under the "ongoing" tab. Check one of two options, MTP or PTP. This would be the same pull-down where you would quickly alter various settings, view downloads and be able to link to recent notifications. This will effectively switch out of installer mode so that you can access your phone's directory and that of any sub sequential micro SD card. Hope this helps.

  • 3
    Yup; that does work, however; that setting isn't "sticking". Each time I plug mine in, it starts in installer mode, and I have to switch it... and sometimes, it randomly switches back. I know... First World Problems, and all... ;) – Andrew Barber Sep 6 '13 at 15:46
  • Yup, this is what I have been doing. I am going to mark this as the accepted answer, but I hope that there is a better solution. – BVB Sep 6 '13 at 19:30
  • 1
    @BVB I've noticed since doing the install that when I connect, it first connects as an installer, and then soon thereafter switches to Media Device. I guess it's checking if it's installed, first. – Andrew Barber Sep 18 '13 at 19:21
  • That's unfortunate. I wish that it was not designed to be like this, but I guess I will have to deal with this poor workflow. – BVB Sep 18 '13 at 19:42
2

In android 4.2, it was possible to access a hidden setup menu and fix the usb settings. The 4.3 update reverted usb setting to the broken default. The access codes for the advanced setup menus have been changed or removed. Samsung claims they've removed access, for what ungodly reason I don't know, and repeated requests and hours on the phone with them got me nowhere.

Until someone can break back into the advanced setup menus, there isn't any way fix this behavior besides rooting the phone or reverting to a previous version of android.

http://www.linuxine.com/story/hidden-services-menu-galaxy-s3-android-43

2

If you have a Verizon Galaxy S5, please follow the instructions here: http://forum.xda-developers.com/verizon-galaxy-s5/general/disable-verizon-cd-installer-t2849481

1.In the phone dial pad, enter but don't dial *#0808#

2.Will now show the following, choose the items with *

USB
( ) CP
(*) AP

USB Settings
( ) MTP
(*) MTP + ADB
( ) PTP
( ) PTP + ADB
( ) RNDIS + DM + MODEM
( ) RMNET + DM + MODEM
( ) DM + MODEM + ADB

[OK] [Reboot]

3.Push "OK" (no need to reboot).

1

In case anyone with a Samsung S4 running USB Mass Storage Enabler and Busybox runs into this issue, be sure that the USB computer connection is set to MTP. This setting sometimes toggles off for some odd reason on my phone. Click the text box and you should be good to go.

0

Are you using a USB 2 port? I had the same issue and I was using a 1.0 port. The issue disapeared once I plugged into a 2.0 port. I have an S3 instead, but it may be the same problem.

  • Yup, I tried both USB 2.0 and USB 3.0 ports - same issue. I think the software on the phone is to blame. – BVB Jan 5 '14 at 6:05
0

I've had the same problem with my Verizon S4 Mini LTE (SCH-I435).

I was able to solve it through the hidden dialer. Here is a utility that was able to bring the dialer back for me, since it wasn't accessible (I am not the author):

http://forum.xda-developers.com/showthread.php?t=2434415

If you'd rather not trust the apk, it just implements this technique: http://forum.xda-developers.com/showthread.php?t=2303905

Once the menu comes up go to USB Settings and change the usb protocol to MTP+ADB. Note, the first time I used it it was already on MTP+ADB. I had to switch to PTP, save come back and switch to MTP+ADB to get it to work.

The settings stick now.

  • The big problem: Does it require root? Yes. :( Thank you for the information, though! I am sure it will help rooted folks! – BVB Jun 22 '14 at 6:23
0

When you plug it in, it says "connected as media device - touch for other options." Click that and then on the next screen turn 'Software Installation' to the off position.

Done. You can now easily access the files on your phone as any other drive.

  • I do not have those options. Do you have a Verizon S4? – BVB May 7 '15 at 19:25
-1

The files needed for rooting are not able to be transferred via MTP, switch to 'Camera' for PTP file transfer and it should work just fine!

  • 2
    How is this relevant to the question, which mentions nothing about rooting? – onik Mar 27 '14 at 6:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.