12

So I have a Nexus 7 that I'm trying to connect to my Windows computer for debugging over adb. Adb works fine with my phone, but when I plug in the tablet and run adb devices in Windows I get an empty list back:

C:\android\sdk\platform-tools> .\adb devices
* daemon not running. starting it now on port 5037 *
* daemon started successfully *
List of devices attached

C:\android\sdk\platform-tools>

The tablet is running stock Android 4.2.2 build JDQ39. USB debugging is enabled, I did click on the build number 7 times to get the developer options enabled, and I've tried connecting both as a Media device (MTP) and as a Camera (PTP). The tablet is not rooted and I have not unlocked the bootloader.

The computer is running Windows 7 Enterprise SP1 x64. I have the latest adb version, 1.0.31. The SDK manager tells me I have SDK Tools rev 22.0.1 and SDK Platform-tools rev 17. I've tried using the Google generic usb driver version 7.0.0.1 and 6.0 as well as the Asus usb_driver_r06 from http://support.asus.com/Download.aspx?SLanguage=en&m=Nexus+7&p=28&s=2. Each driver I try does show the tablet as connected in device manager as either "Android Composite ADB Interface" or "Android ADB Interface"

If I plug the tablet in to my Macbook Pro and run adb devices, I get the the RSA fingerprint dialog as I would have expected to see in Windows:

Allow USB debugging?

Also if I start the tablet in fastboot by holding down the power and volume down buttons. I can see it with the fastboot utility:

C:\android\sdk\platform-tools> .\fastboot devices
015d262e32540802        fastboot

I am completely out of ideas here. Any and all off the wall suggestions would be welcome.

  • 2
    In many cases, it helped using Koush's Universal ADB driver. Worth a try. – Izzy Jun 30 '13 at 21:46
  • Thanks for the link. I couldn't get adbdriver.com installer to detect the tablet, but it did list my phone when I plugged that in. I installed Koush's ClockworkMod driver, but unfortunately I get the same results. – David Hogue Jul 1 '13 at 14:37
13

What fixed it for me was clicking on the "Connected as a media device" up at the top left corner, de-selecting Media Device (MTP) and then checking Camera (PTP). This essentially made it show up as a different kind of USB device with different options and allowed the process to work perfectly.

  • That does seem to be a common cause of the problem, but I did switch to PTP and still got nothing. What finally did work in my relatively unique case was replacing a corrupt usb.inf in Windows. – David Hogue Oct 2 '13 at 17:00
  • My nexus showed up in the list when I unchecked "Media Device (MTP)". As soon as I checked it (or PTP) then it disappeared from the list. – ccallendar Oct 18 '13 at 22:41
9

I have exactly the same device as you, down to the Android version and build number. I discovered that it was necessary to change my USB transfer mode.

You can do this on the Nexus 7 by going to Settings > Storage, clicking on the strange menu icon in the top right hand corner and selecting "USB computer connection". I then changed the storage mode to "Camera (PTP)", and it immediately prompted me with the permission dialog as shown in your post above. I was then able to deploy apps, debug, etc and it all worked.

Unfortunately I am very new to Android development so I am unable to say why this is the case. I am also unable to say why this worked on your Mac. Perhaps this is what must be done with this particular device on Windows. Anyway, I hope that you find this information useful.

  • Thank you for the suggestion. Unfortunately I had already tried both USB connection modes each driver I was able to find. – David Hogue Jul 22 '13 at 20:17
  • David, it is possible that something I did previously fixed this. I also installed the drivers from the Android Package Manager as well as attempting to install the ASUS drivers: support.asus.com/… – Steve Rukuts Jul 23 '13 at 8:40
  • Furthermore I note a difference: You're running Windows 7, and I'm running Windows 8. That shouldn't affect anything but perhaps you might try this on a Windows 8 machine. – Steve Rukuts Jul 23 '13 at 8:50
  • I followed Google's instruction to update the driver from Device Manager, but it wouldn't recognize the drivers. Once I changed my transfer mode on my Nexus 7, I repeated the process and voila it worked. Thanks! – Tony D Aug 7 '14 at 20:28
3

Got the same issue, and fixed it by updating the driver from the ASUS usb_driver_r06_windows.zip driver pack.

The issue is that this driver does not report properly the supported devices (at least mine were not listed)

My device is reported as a PID 4EE2 which is not part of the supported devices.

I had to add the following lines in the android_winusb.inf file (in the Google Nexus 7 Section)

%CompositeAdbInterface%     = USB_Install, USB\VID_18D1&PID_4EE2
%CompositeAdbInterface%     = USB_Install, USB\VID_18D1&PID_4EE2&MI_01

Device now appears properly in the Device List, and the Google Nexus 7 is part of the list of devices in ADB.

In addition, "tap" 7 times on the Settings|About Tablet|Build version to enable the USB Debugging.

3

I finally found my problem. This might have been specific to my Windows machine, but I'm writing it down here in case someone else has the same problem.

Turns out I didn't have a usb.inf file in my C:\Windows\inf directory. Apparently some installers/uninstallers have been known to mess with that file. I found the tip in this thread while trying to figure out why my new mouse didn't work...

I copied the four files from C:\Windows\System32\DriverStore\FileRepository\usb.inf_amd64_neutral_153b489118ee37b8 over to C:\Windows\inf and re-installed the drivers and the security dialog popped right up on the tablet.

  • I too had similar symptoms that seemed to be caused by underlying issues in my USB stack. A complete uninstall and reinstall of my USB drivers didn't immediately solve it, but did cause an option similar to "Composite USB Device" to show up alongside "Google Nexus 7 ADB Interface" in the list of compatible drivers for my phone (under Update Driver, Browse my computer, Let me pick). In my case I had to first tell it to use the drivers for the Composite USB Device, then a new item showed up in device manager which I assigned the "Google Nexus 7 ADB Interface" driver. Hope this helps someone. – rkagerer Jul 18 '14 at 23:58
  • 1
    Huge kudos to your answer David. I had the exact same symptoms. After about 5 hours of trying different things, I finally found your answer. I needed a different folder for my drivers which is an important bit in that thread you linked to. And after that, uninstall tablet driver, reinstall, and it just worked. I was on the edge of just wiping the OS and starting over. – aggieNick02 Feb 16 '15 at 22:28
1

I had to add the following: %CompositeAdbInterface% = USB_Install, USB\VID_18D1&PID_D001&REV_0228 %CompositeAdbInterface% = USB_Install, USB\VID_18D1&PID_D001

If you Go into device manager and open the properties for the Nexus 7 entry, click the details tab and drop the property section down to hardware IDs under value you will see the updated Hardware values. Take these values and add them to the Nexus 7 section of the android_winusb.inf file. Try re-running the driver install. It will complain that the driver is unsigned. Just ignore... ;)

If you are using Windows 8.1, you're going to have to reboot in Advanced Mode with Driver Signatures disablled for this to work. See this post: http://www.howtogeek.com/167723/how-to-disable-driver-signature-verification-on-64-bit-windows-8.1-so-that-you-can-install-unsigned-drivers/

0

Try to delete the key UpperFilters from

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{EEC5AD98-8080-425F-922A-DABF3DE3F69A}

Helped me after 4 hours of trying to connect my Nexus 7 to win 7 64bit.

protected by Community Nov 19 '13 at 19:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.