I updated my Galaxy S Captivate on Rogers to Froyo last week. Debating whether the upgrade was worth it or not. There is one thing that's been really irking me since I did the upgrade: DoubleTwist no longer successfully syncs songs from iTunes onto my Galaxy. On my PC, I set up the playlists I want to sync, and tell it to go, and it only syncs about 1/3 of the songs, telling me that the others failed with unspecified errors, and only 1 of the 5 playlists I selected appears to be able to play.

I've done factory resets of my phone data twice now, and I also tried to format the internal SD card as well (Settings --> SD Card --> Internal SD --> Format SD card). Hasn't helped. I'd switch to WinAmp, but that's having it's own problems (it's not saving when I change the sync options and wants to put all of my library on the phone).

Anyone seen this and/or know how I can fix it. Even a lower level log file so I can get more information rather than some unspecified error would be good.


3 Answers 3


Here are things I would try:

  1. Clear DoubleTwist's cache
  2. Clear DoubleTwist's data
  3. Re-install DoubleTwist
  • Where? On the PC? Is that all in the app's AppData folder, or is there somewhere else it keeps it's information?
    – Evan M.
    Jan 18, 2011 at 15:35
  • On the device. Menu | Settings | Applications | Manage applications | doubleTwist . "Clear cache" if it's available. "Clear data" otherwise.
    – ale
    Jan 18, 2011 at 15:39
  • Well, I deleted everything I could find on my PC, uninstalled the app, deleted the .doubletwist folder on my Galaxy, and no change. Looks like I'm going to have to switch to something else. Tried the lite version of iSyncr, and it worked well. Might shell out for the full version and go with that instead.
    – Evan M.
    Jan 19, 2011 at 15:59

I have doubleTwist and had to visit their support forum a few times for my Droid Incredible. I came upon this when I saw your question:

"Unknown error message for some songs" question on support.doubletwist.com

Link for doubleTwist support forums

This site has proven useful for doubleTwist questions, as the staff, moderators, as well as users try to solve your doubleTwist specific problems on this forum. Not all questions get answered but it's worth searching and trying.

Hope this helps some


After some unrelated investigation today, I think I know why I'm encountering the error, but I don't have a solution to it.

It seems to me that when the phone's internal storage is mounted using the Mass Storage mode, Windows only sees the first 2.2GB of space. If I try to format it using Windows, I only get an option to create a 2.2GB FAT32 partition. If I format using the Captivate's formatting tool, it creates a 13.03GB partition. Now the fun part:

The Captivate seems to be able to read/write from the whole 13GB partition fine. However, Windows seems to be only to access the first 2GB of that 13GB partition. While I can see all the files listed, trying to read from file that were created after the first 2GB returns an error, and trying to copy additional files from windows to the internal storage once the 2GB limit is reached results in an error.

I'll open up a new question about this to see if anyone has an answer. Thanks.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .