My GT-I9000 device recently got stuck in a bootloop, and now I'm trying to put CyanogenMod on it, hoping that this would fix the situation.

I can use Heimdall to install the ClockworkMod Recovery on the phone, but as of today, I cannot boot into the recovery!

Yesterday everything worked normally, but once I tried to boot into it today, it got stuck in the bootloop instead of going to recovery!

I'm using the standard Vol up + Home + Power button combination.

What can I do to force the phone into recovery mode again?

Edit: CWM flashed (but unable to start) and honestly I can't remember how I initially bricked the device. I think it's safe to assume that I have a broken ROM on it.

I actually am trying to install a new ROM, so if I could flash it that would be great. But for that I need to get the recovery and ADB working.

  • I'm not sure if you already successfully flashed CWM. But assuming you did, and have not yet "fixed" the ROM itself, that could be the culprit. I have not worked with Samsung devices yet, but AFAIK you can bring them into two other modes for flashing: fastboot and download mode. Heimdall should be able to detect them at least in one of them. Maybe an "experienced Samsung-Flasher" can provide more help here. – Izzy Jul 2 '13 at 20:08
  • i can easily get it into download mode and use Heimdall to flash the device with CWM, but the problem occurs when I try to boot into the CWM Recovery I've flashed onto the device. I was able to do that before, but not anymore, which is weird. – jcora Jul 2 '13 at 20:17
  • Have you already flashed another ROM, including a wipe? As I wrote on the previous question, it very much looks like something is messed up with your "old" ROM, so flashing a new one could solve that. Please edit your question and include the full current state of your device (CWM flashed? CM or another "fresh ROM" flashed?). Thanks! – Izzy Jul 2 '13 at 20:23
  • Also I did the edit btw – jcora Jul 3 '13 at 14:10
  • Any error message from CWM? Sure you've picket a compatible version of it? – Izzy Jul 3 '13 at 15:08

I also had a boot loop today, after flashing Semaphore's ClockworkMod Recovery according to these instructions, then trying to boot to recovery mode. What helped me out was the hint at the bottom of that page: to use Replicant's recovery.img instead:

heimdall flash --KERNEL recovery.img --no-reboot

Update: Note that the hint has now been removed with the comment:

Using a non-Gingerbread-compatible recovery for initial install will result in lost IMEI.

  • Oh my God!! I thought the phone was lost until I tried your image. Finally CWM recovery that works! Thank you! – Avrahamshuk Sep 22 '14 at 18:22
  • Robert, you deserve a medal... – Francisco Luz Feb 9 '15 at 15:38

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.