0

I am trying to use my android phone connected to my PC as an SMS gateway by executing AT commands.

I have attached the phone to the PC (Windows 7), and device manager shows that it is in COM4 port. I opened PUTTY in administrator mode and tried connecting to COM4 but it just shows a black screen with the green cursor but won't let me type anything.

I tried playing around with the values of "Local Echo" and "Local Line Editing" as I found in one of the suggestions in another question here, but the best I can get (set both to "Force On"), I can type stuff on Putty but it doesn't really do anything.

Any suggestions?

4
  • How exactly have you connected your phone to your PC? Most phones don't have a user-accessible serial port.
    – Dan Hulme
    Jul 3, 2013 at 15:21
  • @DanHulme I am using a regular USB connection. From what I've read online, this would create a virtual com port connection which it did as I checked from device manager. I'm trying out with putty if I can send messages using AT commands as I'm planning to build an application that will send SMS using the android phone as an SMS gateway.
    – John Ng
    Jul 5, 2013 at 22:38
  • You can't use the USB connection like a serial connection to a modem. That's just not how it works. You can probably find an app that acts as a server through Wi-Fi to send SMS messages, but I don't think you'll find anything that accepts AT commands.
    – Dan Hulme
    Jul 5, 2013 at 22:42
  • @DanHulme I thought I read somewhere that can be done. I think the app is a better approach. Will this app be something like this: play.google.com/store/apps/…
    – John Ng
    Jul 5, 2013 at 22:50

1 Answer 1

1

You can only do that on phones or 3g devices that are recognized as modems by the os.

I had one Nokia communicator that I used for that and controlled this using at commands. Also I had a Sony laptop with a 3g card that could be controlled with at commands and inclusive enable the hidden gps :)

That Sony still sends his coordinates to my Web server so I know where he has been :) if stolen :)

You need to check if your hardware is compatible and the OS has the correct driver implementation.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .