I have an Android 4.0.4 tablet, Navon Platinum Explorer.

When I try to turn on wifi, the toggle button goes "off" after a few seconds automatically. It doesnt even show the list of available networks.

In Wifi-Advanced, there is MAC Address - Unavailable.

The Wifi worked before doing a factory reset. I also tried turning the table off and on, but it did not help.

What can I do to make the wifi work again? I do not want to root the tablet.


3 Answers 3


I have no idea why,

but rebooting second time and trying to turn off/on the wifi icon on the homescreen several times did finally work.


I too had the same issue after I flashed a new kernel to my HTC Vivid. My Wi-Fi always showed "Turning on" but never did, and my MAC address showed "Unavailable".

Turns out the problem was as simple as a faulty file in the Android system.

  1. Try finding and replacing the file named bcmdhb.ko located in /system/lib/modules. (You'll need root access and a root file explorer)

  2. Download the appropriate file for your phone, boot your phone into recovery/fastboot and plug it into your computer.

  3. Now using CMD and enter the command:

    adb push /users/<USER_NAME>/Desktop/bcmdhd.ko /system/lib/modules 

    (replace <USERNAME> with your username in computer)

    To save time, I moved all my ADB files to the same folder as my bcmdhb.ko and any other phone related file boot.img's, and more.

  4. Hold Shift and right click a random spot inside the folder and select the option "Open Command Window Here". That starts your CMD operation right from the location you need, rather than ever having to cd to that location.

    Note that doing the shortcut I mentioned does not mean you only type adb push bcmdhd.ko. You still need to tell CMD what location to push the file too. So you still have to type adb push bcmdhd.ko /system/lib/modules.

  • You wrote "Quoted" at the end. I assume you forgot to mention the source from where you learned these steps. Please mention it now.
    – Firelord
    Commented Aug 8, 2015 at 8:24

The app Blade Wifi Fix fixes this issue on a lot of phones.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .