1

I have a problem while connecting my Samsung Galaxy Y Duos to my computer using a USB cable. My mobile displays "NO memory card. YOU cannot view Your photos, music etc"

I do actually have the memory card in the mobile. What can I do about this?

  • Did you try another SD card on your phone and did you try reading your current card from somewhere else? (Maybe a card-reader connected to a PC or another device compatible with SD cards?) – Sid Jul 5 '13 at 9:23
  • Actually I dont have an External sd card..my phone memory is 3GB .i cant access the photos stored in that memory space – – maheswari Jul 12 '13 at 13:10
3

While the phone is connected as a USB mass storage device, it's giving the PC sole access to the SD card. The phone can't access the card at the same time because of how the USB mass storage protocol works. That's why newer Android phones use MTP instead: a different protocol that lets the phone and the PC access the SD card at the same time.

To keep the SD card available on the phone while it's connected to a PC, change the USB connection settings so that the phone is not acting as a USB mass storage device. I don't know exactly how the settings work on that phone, but if you click on the Connected to PC (or similar) notification it should take you to the appropriate settings page. There you can switch to MTP if your phone supports it, or to Charge only if it doesn't.

  • It's often found in Settings in the "network" section as USB Connection Mode. But be aware that not all devices/Android versions support MTP; in any case you can switch to "Charge Only" to avoid your SDCard being unmounted from the device. – Izzy Jul 5 '13 at 12:07
  • Actually I dont have an External sd card..my phone memory is 3GB .i cant access the photos stored in that memory space – maheswari Jul 12 '13 at 13:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.