0

I have a rooted HTC Desire HD with a Custom Rom. Now, I want to permanently delete the stored images on my internal memory (/data). Everytime I run the app Disk Digger, my old crappy photos seems to show up. I tried flashing again and again and doing a a factory reset again and again but the images seems to be always there. All i want is to remove that images from my internal memory so i can safely sell my phone. Can anyone help me? BTW, the exact location where the disk digger digs is /dev/block/platform/msm_sdcc.2/by-num/p26.

Can someone help me here?

migrated from superuser.com Jul 5 '13 at 9:00

This question came from our site for computer enthusiasts and power users.

  • It is not the best suggestion: fill your memory full, then empty it. Repeat that procedure as much as you can. This will overwrite new data onto your old data which will decrease chance for someone else could recover your data. – angs Jul 4 '13 at 19:27
  • This is the wrong site for this (I've flagged for migrating it), but it's very likely if the phone is linked with Google that they are redownloading the pictures because they see they've been deleted – Canadian Luke Jul 4 '13 at 19:41
  • I have only Internal memory. I removed my SD. You mean I will fill my internal storage with files until it becomes full then i will do factory reset? Is that what you mean? – Kerv Jul 4 '13 at 19:44
  • Krev, are you a linux user or windows? – angs Jul 4 '13 at 19:53
  • iam windows @angs – Kerv Jul 4 '13 at 20:00
0

Perhaps the reason why your old photos survive flashes is because there may be a secondary internal flash memory that is separate from both the memory used for the OS (root) and the removable microSD slot. (I know my phone is like this.) Not sure why they would still be there after a factory reset though. Have you tried removing them using a file manager app like ES File Explorer, ASTRO, etc?

Another suggestion would be to verify that the photos aren't owned by root. If they are you could try removing them using the Android Terminal EmulatorAndroid Terminal Emulator app with root privileges, or try connecting your phone to your computer and delete them using the Android Debug Bridge.

  • I tried it deleting but it always fails. I tried with Terminal Emu, ES File Explorer, File Manager but It can't be deleted. – Kerv Jul 4 '13 at 19:48
  • That's weird. Are there any warnings or errors when you do so? When you used Terminal Emu did you run rm as root ie using su? Do you have the Superuser app installed? – Roberto Gomez Jul 4 '13 at 20:07
  • Yes. Oh yes, i forgot the su command. Sorry. maybe i'll try. I'll update you. – Kerv Jul 4 '13 at 20:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy