15

How can I stop Google play from automatically updating to the latest version? I tried deleting my hosts file but it's not being deleted. My phone is rooted.

  • 3
    Please clarify if you are attempting to stop Google Play from updating other apps or updating itself. Your original wording suggests the latter, but you have not provided much detail. – eldarerathis Jul 7 '13 at 17:30
  • 1
    Do you know that you can mark the answer as accepted by clicking the tick right below the vote down button? – Sid Aug 7 '13 at 5:50
8

You can stop apps from being auto updated in the following way.

  • Go to Google Play Store app.
  • Click the menu button and click settings
  • Select Auto-update apps Under General
  • Choose Do-not auto update apps
  • 8
    I'm not sure that this is actually addressing the question the OP was asking (and I've reverted your edit to the question for now). The original wording suggests he wants to know how to stop Google Play itself from updating to the latest version, not how to stop it from updating other apps automatically (though it's somewhat unclear). – eldarerathis Jul 7 '13 at 17:26
  • Alright. Will change this once the OP replies. Thanks for the heads-up!!! :) – Sid Jul 8 '13 at 0:56
  • @eldarerathis: Would you mind deleting this? It's so annoyingly wrong. Also the one below it... – Mehrdad Aug 13 '16 at 18:43
  • @Mehrdad Although this particular answer is not answering the OP's question, it's a working answer to a different question ;) As for the other answers on this page, they're all wrong. People up-voting them think that making stuff read only fixes the issue. It does not. File is still downloaded. Installation progress is ALWAYS hidden for these unauthorized updates, but download progres may or may not be hidden. Completion is not displayed. So if you have fast connection and didn't look at the phone, you won't know it tried downloading something. At the moment I found zero workable solutions. – Emil Sep 3 '17 at 11:21
  • @Emil: No, the -1/-2 answer is correct. I replied to your comment there just now. – Mehrdad Sep 3 '17 at 11:56
6

Turns out the answer to this problem was quite simple, in order to disable Google play store (1)

  1. First, you must have version 4.8.2 installed (just replace it in /system/app with the new com.android.vending.apk)
  2. Download a root service from the store called "Disable service" (again make sure root is installed and the app is given root permission)
  3. Now, in the disable service app, navigate to the system app tab and find Google play store. Tap on it and you will get a list of services
  4. Scroll to the bottom and uncheck "check Wifi And Update" service.
  5. You will see a "please wait" notification, and at the bottom busybox should appear, notifying you that the app was given root access
  6. Exit the app and voila! Google play store will never update itself or Google play services ever again (unless you install a new version, in which case you would need to repeat the process)
  • 2
    Where can I find version 4.8.2? – ceiling cat Oct 15 '14 at 20:07
5

First, you must have version 4.8.2 installed (just replace it in /system/app with the new com.android.vending.apk)

Instructions (found https://www.youtube.com/watch?v=3JI6YNSpAz8):

  1. root, install supersu
  2. install busybox, then terminal emulator
  3. stop whatever internet access on your android, or it will silently auto-update store, making your hard typing work useless
  4. open settings -> app manager and find play store. tap on it. it will open properties window. there will be button Uninstall Updates. Tap on it, click yes on "replace with factory version?" question.
  5. because there is no internet connection, this is the moment the play store couldn't be updated. let's use it.
  6. open terminal emulator and type commands one by one (numbers are just for order, don't type them):

su

(at this time supersu app will ask you for granting root access for terminal emulator app, click grant access)

touch /data/app/com.android.vending-1.apk

chattr +i /data/app/com.android.vending-1.apk

Enjoy! Regardless of internet connection, play store is now has version YOU need, not GOOGLE. This might work for Play Store 4.8 and up, but I didn't test it.

  • +1 The answer that actually works. Note that you may have to replace -1 with -2 if that already exists. (But don't go to -3!) – Mehrdad Aug 13 '16 at 18:44
  • This will not solve the problem, because it will keep downloading the whole thing into a temp folder again and again and again... – Emil Sep 2 '17 at 17:49
  • @Emil: "Downloading" doesn't imply "updating". The question was about how to prevent updating, not how to prevent downloading. – Mehrdad Sep 3 '17 at 11:56
  • @Mehrdad this is not about linguistics. Do you believe it's an acceptable solution to the problem that after each reboot the app would be downloaded again, forever and ever? – Emil Sep 3 '17 at 12:08
  • @Emil: Yes, 100%. It's literally what I did to solve this problem last year and I didn't even know it downloads the app until you just told me. – Mehrdad Sep 3 '17 at 12:10
2

A modified version of Stephen Schrauger's steps, based on the video here, since chmod +i returned an error on my phone. Tested on Android ICS (Cyanogenmod 9, Play Store 3.*).

Assuming a rooted phone:

  1. Stop whatever Internet access on your Android or it will silently auto-update Play Store, making your hard typing work useless.
  2. Open Settings → App manager and find Play Store. Tap on it. Tt will open properties window.
  3. There will be button Uninstall Updates. Tap on it, click yes on "replace with factory version?" question.

Because there is no Internet connection, this is the moment the Play Store can't be updated. Let's use it.

Open Terminal Emulator and type the commands one by one:

su

At this time supersu app will ask you for granting root access for Terminal Emulator app, click grant access.

mkdir /data/app/com.android.vending-1.apk

Instead of creating a file and preventing modification with permissions it just creates a directory, which can't be overwritten by the updater.

Now you can re-enable the internet connection and it will not update unless the directory is deleted.

1

In the system folder there should be MarketUpdater.apk. If you delete that file, Play Store won't update itself anymore. Nothing else should be affected though.

  • I couldn't find that file, I think they've discontinued it some time ago. – Emil Sep 14 '17 at 20:22

protected by Community Aug 9 '16 at 9:49

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.