0

I've googled this and turned up a bunch of inconclusive forum threads. I've also checked out a few similar questions on this site, but none of them quite match my details. So here they are:

I have a Galaxy Tab 2 (7.0) that's been working fine with my wifi router since I got it about 6 months ago. This morning when I fired it up, it rebooted and now I cannot connect to my wifi router. My wifi is not the issue as my Nexus 7 tablet is connected and working.

This is what I see:

  • When I go to Settings > Wi-Fi, I see my network listed. But status is stuck on Obtaining IP address
  • After a while, status reports Network disabled. Poor connection

Tablet also reports that a "Software Update" is ready. Not sure if this is related to the issue. But when I try to update, I get a confirmation page and when I hit confirm button, I get message Unable to connect network.

I've tried the following:

  • Rebooting tablet
  • Forgetting and reconnecting to my network through Wi-Fi settings
  • Read this solution, but couldn't find Mobile Network Settings

Here's some system data from my tablet:

Model Number: GT-P3113
Android Version: 4.0.4
Kernel Version: 3.0.8-999349
Build Number: IMM76D.P3113UEBLH2

A simple solution would be appreciated. I'll post a solution if I figure it out myself. Thanks!

1

When in your WiFi settings, could you try pressing menu (or clicking the overflow dots), and selecting Settings.

Once done, untick the Avoid poor WiFi networks option, and see if it will now connect.

Also, restart the router.

  • Thanks for suggestion. Looked all over settings for the Avoid poor WiFi networks option, including in Advanced Wi-Fi Settings, but don't see it on my tablet. – klenwell Jul 7 '13 at 20:04
  • Unplugged my router for 30 seconds, plugged back in, problem resolved. – klenwell Jul 8 '13 at 4:55
  • Can you help me ? I can't find the settings button in the overflow dots, it just show up Advanced,WPS push button and WPs PIN entry,where's the settings button? – user59582 Apr 29 '14 at 11:28
  • @user59582 it's the Advanced menu. – Liam W May 1 '14 at 10:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.