I have samsung galaxy ace GT-S5830, it has very low internal memory (181 MB). I have an external micro SD card of 16 GB, but still couldn't install many apps due to insufficient internal memory. I read in internet that if i modify vold.fstab and replace the word sdcard with sdcard2 in it, then my external sd card will act as internal memory.

So I rooted my phone and got superuser app (which can allow root access to various user apps) But I haven't installed clockworkmod recovery or any other custom ROM yet.

I installed ES File explorer on SD card and allowed root access to it via superuser app. I then went to /system/etc/ from ES file explorer , edited vold.fstab and replaced the word sdcard with sdcard2 Now i restarted my phone and the external SD is no more accessible. My "ES File Explorer" is also no more there for me to able to undo the change that i did. I tried intalling ES file explorer again from my data connection, but the installation fails (and phone reboots immediately). I am not able to install any new apps.

I am unable to access my external SD card, so I can't put anything there via PC or via recovery.

I tried pressing the power button + home button to go into system recovery mode. I see only these options

Androd system recovery <3e>

  • reboot system now
  • apply sdcard:update.zip
  • wipe data/factory reset
  • wipe cache partition

When i try to select the second option, it says installation aborted as the SD card is no more accessible

I tried to select 3rd and 4th options, but that didn't help either - I think factory reset will not reset vold.fstab :-(

I only have the default apps + superuser app now

I somehow need to find a way to get write permission to /system/etc or to /system/etc/vold.fstab

Luckily I found "Android Commander". Installing it on my windows PC and I am able to connect my android phone and I am able to access root folder. But I am not able to push a modified vold.fstab to /system/etc because Android Commander says "no Root Access" - It is seeing it as read only :-(

can someone let me know how i can edit this file again ? I have a original vold.fstab in my PC, but I am not able to push it to my phone via Android Commander as Android Commander is seeing it as Read Only.

Is there a way to give root access (aka read-write access) to Android Commander via superuser app on my android ?

Is there any other way to get write permission to /system/etc/vold.fstab so that i can modify it or replace it ?


1 Answer 1


I don't know about Android Commander, but a simpler way (in my opinion) would be to use ADB. You may have already installed the Android SDK (if not, go here). I assume that you don't have modified your System Path.

  1. Move your vold.fstab to C:\Program Files\Android\android-sdk\platform-tools or C:\Program Files (x86)\Android\android-sdk\platform-tools
  2. Go to the android-sdk folder, shift+right click on platform-tools and choose "Open command prompt here"
  3. If your device is 4.0 or above, type adb root
  4. adb remount (this will make /system writable)
  5. adb push vold.fstab /system
  6. adb reboot

This should do the trick.

  • my device is having froyo 2.2.1 and phone model is Samsung Galaxy Ace GT-S5830
    – aks
    Jul 7, 2013 at 20:25
  • I'd remove windows specific instructions as they're not related to the question.
    – pevik
    May 18, 2015 at 10:16

Not the answer you're looking for? Browse other questions tagged .