0

I'm using CyanogenMod-7.2.0-passion on my Nexus One, and there's a feature in CM7 that's bothering me. During a call, if the large red-colored "End call" button is long-pressed, it gives a popup asking "Add to blacklist". I do not want this feature, but it gets unintentionally activated by my cheek (which manages to press the "Yes" button of the popup too!) when I'm on calls. I've missed several calls from friends and relatives due to this.

So, is there a way to disable this feature? I've googled a lot, but there are only posts about how to remove people from blacklist after they get added there, nothing about how to prevent this whole mess. I don't want to be checking the blacklist every day to make sure someone new hasn't gotten added that day, so I hope there's some setting somewhere to disable this function.

  • While it doesn't answer your question: I do not understand how your cheek should be able to do that. Usually, the proximity sensor should have deactivated the screen before your cheek is close enough for that. Is there something wrong with your proximity sensor -- or does the N1 not feature any such? – Izzy Jul 9 '13 at 18:32
  • N1 does (theoretically) have the feature, but it frequently seems to fail in its sensing, and I often have calls 'Mute'd unintentionally too (though in that case I at least immediately get some indication from the other person that they're not hearing me, so it's not this big a problem). I try to lock the screen before speaking, but sometimes I forget and sometimes the caller is in a hurry, so it doesn't solve the problem for me. – sundar Jul 9 '13 at 18:42
  • Thanks for the additional details! No, I didn't expect my comment to solve your issue; I just was curious. Well, a flaky sensor explains a lot. But I have no idea how to disable the blacklist, sorry. Have to leave that part for somebody else. – Izzy Jul 9 '13 at 19:56
  • Just a thought: You might want to take a look at Smart Screen Off. According to a post on XDA, this seems to offer an option to calibrate your proximity sensor. With the underlying problem solved, your issue should be gone :) – Izzy Jul 9 '13 at 21:42
  • Hi @Izzy, thank you very much for the suggestion. While the "Smart Screen Off" app had too many false positives and didn't work for me, it led me to find a "Proximity Sensor Finder" app, with which I've been able to find the proximity sensor's location on my phone. It's in the top left corner apparently, and I used to hold the phone such that that part remained exposed, which must be the reason for all this hoopla. Now on I'm going to try and "hold it right" - if the iPhone guys can do it, why can't I? ;) – sundar Jul 21 '13 at 5:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.