6

I had a Intex iBuddy Connect (Tablet) linked with my Google account.

Later on I purchased an new Android device (a XOLO Q700). I logged into Google Play from my device and I am able install apps to the new device.

But when I log in to Google Play from my laptop and hit install the list does not show my new device. Only my old device is listed in the list of devices.

What would be the issue in linking my device with my account?

4

Be patient, it can take a while for your device to show on there

  • 1
    what is a while? a while is very relative – davejal Oct 12 '16 at 1:38
  • 1
    One of my devices is not showing in play.google.com for two months – Maris B. Nov 28 '16 at 10:25
  • 2
    over a year and still nothing – John Demetriou Jan 26 '17 at 14:40
5

I had a similar issue (new device can install from Google Play, but from the website it wasn't being shown as a device under my Settings).

What I had to do was to go into Settings/Apps/Google Play on the device and then clear the data. Once that is done, when you next launch Play, it will ask you to accept the terms and conditions. Then I just downloaded an app (any app will do) on the device. This seems to alert the web settings that there's another device.

I then checked my settings on the Play website and the device was now listed (no delay, it was there straight away). Note that I never logged out of the Browser, or cleared any browser caches etc. Effectively the step are:

  1. Clear the Google Play app cache on the Android device.
  2. Start Play and accept T&Cs
  3. Download any app from inside the Play app.

Hopefully this will work for others too.

  • This method works! – Maris B. Nov 28 '16 at 10:37
0

Have you tried singing out on both pc and device google (ever stuff) accounts then history / catch erase

  1. Un sync old device from the gmail address via your google dashboard settings then on device delete and re associate new device by add account on sign

  2. even though the device is new AND listed as compatible you may need to go to 'market' to download 'google PLAY' app. yes i no sounds silly but true story..

  3. go into device settings -- to applications and sync ---into device accounts / add account---ensure weather or not the data background is on if it is green or enabled try this back out to network n wifi and go to AIRPLANE MODE enable then disable Remember upon completion -- to ENABLE SYNC or turn on sync Across Platforms .............

    the only reference to the suggestions above is personal experience ... first 1 should work tho Good luck ;-)

Not the answer you're looking for? Browse other questions tagged or ask your own question.