I own a nexus 4 and since then i am unable to download anything via 2g/3g. I am able to download content only through wi-fi. The same applies for PlayStore. I have even tried in safe mode. I have tried to clear data of Download Manager and even Playstore but in vain Please help.

  • What kind of content are you trying to download? Is it only through Google Play, or something else as well? – Dan Hulme Jul 11 '13 at 20:54
  • Any app from playstore and also general content like images,songs etc...The same can be accomplished via wi-fi. – Aditya Kamath Jul 11 '13 at 21:03
  • This might be obvious, but did you pay your phone bill? – Michael Hampton Jul 12 '13 at 2:58
  • lol...I have paid..:D – Aditya Kamath Jul 12 '13 at 3:55

I finally solved the issue. It was related to my APN. My Access Point allowed only browsing. I changed it to another access point, and it worked!


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.