I have PAC-ROM Paranoid-Android (downloaded and flashed from here), and suddenly, after changing some settings (unfortunately I can't reproduce an annoying message started popping up every 2 seconds, it says "Unfortunately, System UI has stopped.".

Has anyone faced this before?
Does anyone know how to reproduce the issue or what setting is causing that? I'm sure reflashing the ROM will solve the issue, but I prefer avoiding a reconfiguration of all my personal settings.

I'm noticing now, that since that message started to bug up, the status bar is gone.

  • Did you wipe cache before flashing?
    – t0mm13b
    Jul 22, 2013 at 14:36
  • @t0mm13b yes. Anyway, look at my answer. Issue solved. Jul 23, 2013 at 0:58

2 Answers 2


This is a symptom of a programming or integration error in the custom ROM. System UI is the name of the process that draws things like the soft home/back/recent buttons and the notification tray. When this process crashes, the soft keys and notification tray, along with anything else it's responsible for, will stop working.

The error could be in their UI customizations, or in something fundamental like the GPU or framebuffer drivers or the kernel. You should report this error to the developers of the custom ROM so that they can fix it.

They'll certainly need more detail to find the problem, such as what device you're using, what settings you changed to make it happen (reproduction steps in technical parlance), and they'll probably ask you for more information too. This answer tells you about getting crash logs using adb logcat and the bugreport command.

Of course, if there's already a newer version of the ROM, the developers will probably not be interested in your bug report unless you can also make it happen on the latest version.

  • :( I can't really reproduce it. I guess I'll have to reflash it. But it worked for a week until the error started popping up like crazy as it's now. Jul 15, 2013 at 13:03
  • 1
    If you reflash the same ROM and change the same settings again, it will probably start happening again.
    – Dan Hulme
    Jul 15, 2013 at 13:32

Enabling quick settings made that popup disappear (Source).

It's at Settings->System->Status bar->Quick settings.


  • While it's good that you managed to reproduce it, this should go as a bug report to PA devs, it's a bit too specific to be a useful answer for Android users in general.
    – pzkpfw
    Sep 5, 2013 at 6:56
  • I wish I'd have a more general answer :( I thought I should share at least this and it might be of help to someone in the future. Oct 20, 2013 at 6:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .