So I've recently upgraded to the Samsung Galaxy S4 from the iPhone 4. I seem to have correctly added my yahoo mail account. However, every time the phone checks for mail, it will indicate that I have 17 new messages, when in reality there may only be three new messages. What is happening is that as I delete messages, the phone seems to be pulling older messages from my yahoo account and loading them as new, even though they have already been read on my PC. At first I just re-read them on my phone to clear the icon number indicator, but the the minute the phone does another push from my account, it happens all over again.

The Verizon tech person there's nothing I can do about this, but I can't believe that's true. Any help on how to solve this would be greatly appreciated. Thanks, Marcella

  • Hi, I see you're new. If you feel an answer solved the problem, please mark it as 'accepted'
    – bmdixon
    Jul 18, 2013 at 8:38

3 Answers 3


This sounds like you're using POP3 to access your email. This doesn't sync read status back to the server. Can you configure your email using IMAP? Take a look here and use these settings

  • bmdixon,THANK YOU!! That seems to have solved the problem!!
    – user37714
    Jul 17, 2013 at 17:52

Go in the email settings and remove the limit settings, just let them all load instead. I've done this and it works so far I don't get notifications for my older emails.



Also if your email subdivides your Inbox into new and old mail, the phone reads both as Inbox and will load everything in both folders as new mail to the phone.

Easiest thing to do is to create an alternate folder for those old mails you want to save and moving them in there. That way they will be removed from the Inbox.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .