5

Here's my situation:

I have a Sprint Samsung Nexus S 4g. It is rooted, unlocked, and loaded with CyanogenMod 10.1. I am attaching it to a Windows 8 machine via USB cable.

Recently, the phone went into a boot loop, and thus I can only do anything with it in recovery mode.

I'm trying to transfer the stock ROM to the phone for loading. I follow these steps

  1. I boot into Recovery mode
  2. I go to Mounts and Storage
  3. I mount the USB card
  4. In Windows, I open up the phone in explorer, and copy the update.zip file to the root of what is now the G: Drive on my phone.
  5. I try to load the ZIP file for processing. Recovery says "Can't open file /sdcard/update.zip"
  6. I reboot into recovery again to 'refresh' things.

At this point, the file that I loaded is gone! It's not on the SD Card anymore. I can't find it via Recovery mode, and if I remount the USB disk, it's not visible in Windows either. Weird, huh?

One other thing to note: I've wiped and reformatted everything I can via Recovery (Cache, system, data, Dalvik, everything) and yet when the phone occasionally manages to boot all the way to the OS, I can still see my wall paper.

How can I get the files I copy over to actually stay on the phone? Any ideas on what is going on?

I just want to wipe this phone and start over, but I can't seem to make that happen.

Thanks.

More:

Okay, I formatted and wiped everything that I could. And now the phone only boots to fastboot mode. I mount the USB card, move a ZIP over, and double check it in Windows. I can open the file on the phone. But when I unmount the USB card (I have no choice), the ZIP is there, but the phone won't read it. It says "Can't open (bad)". This is trying with CM9.1 and I'm 100% sure it is the right version for my phone (crespo4G)

  • which recovery do you use on your phone? – Alok Shankar Jul 19 '13 at 9:44
  • 1
    Wait a second: You wiped system and data, and the phone still boots up? That's impossible if the wipe really worked, as there is no system to boot. The only logical explanation to that is a misbehavior of the controller in your FLASH chip, which does no longer obeys write commands (including wipe). If that's the case, there's nothing you can do; you'll have to turn it in for service, which will either replace the FLASH chip or (cheaper for them) the device. And most likely make you pay for it (if you're living outside the EU), as you voided your warranty :( – Izzy Jul 19 '13 at 10:45
  • When you say stock ROM, it will not work just by dropping it into your SDCard and use the recovery to handle it - you either need the appropriate software for your device or if its compatible with ODIN for flashing. Another aspect, consider this - you say you've wiped and reformatted everything the phone cannot physically boot, unless recovery is "mis-leading you" @Izzy pointed out that it could well be the NAND Flash chip is misbehaving, thus recovery, did not really wipe it. Best to hunt for the original stock firmware that is Odin compatible and use that instead... – t0mm13b Jul 19 '13 at 11:32
  • @izzy --- yes, that is correct. I wiped everything, and the phone still boots. – Nick Hodges Jul 19 '13 at 13:34
  • Alok -- I have ClockworkMod Recovery v5.0.2.0 – Nick Hodges Jul 19 '13 at 13:35
0
  1. Try downloading the update.zip again to ensure it's not a bad download.
  2. Try updating your version of ClockworkMod Recovery, i think the latest version for your phone is 6.0.3.1. Get into fastboot mode and ensure you have the drivers installed. You can flash this by downloading the relevant file and running the command fastboot flash recovery <recoveryfile>
    (replace with the filename of the recovery you downloaded (eg recovery-clockwork-touch-6.0.3.1-crespo4g.img)

If that fails you could try flashing the factory image again. Download the factory image from here and unzip. There should be a flash-all.bat which will restore your phone to stock. Note that this operation deletes all user data by default. (although i guess you've already wiped so nothing left to delete!)

  • How do I run flash recovery? adb doesn't ever see the phone. – Nick Hodges Jul 19 '13 at 19:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.