3

In Swiftkey how do you right an apostrophe (') for words like "can't", "hasn't", or "the dog's bone"? Is there a way to do it without taking your finger off the keyboard and going to another menu?

At the bottom there is no apostrophe like there is in swype, only a period. To get to the apostrophe you need to click on the button that says "123" but that requires taking your finger off the keyboard. Auto correction/auto detection has nothing to do with it since using an apostrophe to show possesion can is just as allowed as not having an apostrophe there to show plural e.g. The dogs bone vs The dog's bone.

  • How do you use SwiftKey Flow ? If not, you just have to type on the dedicated touch. It is with the lettres. – air-dex Jul 22 '13 at 0:34
  • @air-dex I cannot understand what you are saying. – Celeritas Jul 22 '13 at 5:11
  • I asked you how you use SwiftKey. Do you use "SwiftKey Flow", the SwiftKey feature which enables you to write words just like Swype ? Or do you write words just like on a classic keyboard, by tapping on virtual keys ? – air-dex Jul 22 '13 at 22:02
  • @air-dex in settings it says SwiftKey flow is enabled. Does that answer your question? – Celeritas Jul 22 '13 at 22:20
1

I think that it is due to the keyboard layout.

SwiftKey's QWERTY layout do not put the ' key in the "abc" part of the keyboard. If you want to type a ''' with the QWERTY layout, you have to go to the "123" part of the keyboard and then type on the ' virtual key.

But unlike the QWERTY layout, the AZERTY layout has got the ' key in the "abc" part of the keyboard :

SwiftKey with the AZERTY keyboard layout

To switch to the AZERTY layout, go in SwiftKey settings > Languages and layouts. Then go to the keyboard language (the one you use) and type on the keyboard icon near the checkbox. Then select "AZERTY" when the list of available layouts is opened.

  • I tried and both QWERTY and AZERTY appear to have the ' character in the 123 menu – Celeritas Jul 22 '13 at 22:33
  • 1
    Yes but with the AZERTY layout ' is ALSO in the abc menu. Look at my screenshot (and your phone too ?). – air-dex Jul 23 '13 at 2:53
2

The way I do it is to have space insert the suggestion. That way I write cant and hit spaces and Swiftkey inserts the suggestion of can't in its place. I basically never use the apostrophe key.

1

I am not an user of Swiftkey, rather an user of Swype. I am suggesting this with an assumption that both apps should not be miles apart in their feature.

In Swype we can do this by moving the finger through apostrophe, considering it as a part of the word. So, if you would like to type can't then start swiping on c, to a, then to n, then to ', and finally finish at t.

You can see this demonstration video as well.

  • Yea I used to be a user of swype and I know what you mean. The problem is the apostrophe isn't on the same menu, you have to go to the other menu to get to it. Know what I mean? Like how the dollar sign isn't available in the default menu (or whatever it's called). – Celeritas Jul 22 '13 at 5:41
  • Still can you swipe through the key assuming Swiftkey will be intelligent enough to interpret and give a try? – Narayanan Jul 22 '13 at 5:43
  • It seems there is someone who raised this to Swiftkey's support - see whether it helps. – Narayanan Jul 22 '13 at 5:48
  • But this is different because they are talking about words that always have apostrophes. For example "Im" isn't a word so it obviously should be "I'm" where as "Dogs" is a word and "Dog's" is another word that shows possession so auto correct is not applicable in this situation. – Celeritas Jul 22 '13 at 5:52
  • 1
    I tried and the screen shot is what is shown. – Celeritas Jul 22 '13 at 5:57
0

If you hold down on the 'v' key for a brief pause it will type the secondary character, which for that key is the apostrophe. Each key has a secondary character which is shown in black in the top right corner of the key.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.