Periodically, when I try to use Google Drive for Android, it will show the list of documents, and when I click one, it says:

"Failed to open the document. / Unable to open the document. Please make sure you are connected to the Internet and have permission to open the document and try again. / Cancel / Open in browser"

I had the problem Tuesday and couldn't open any documents; by Wednesday it was normal again; today it's back and I can't open any documents. The app is the newest version and has not released any upgrades in the meantime, so I'm thinking it may be caused by the server. Is that plausible? Is there a fix?

I am using Cyanogenmod 10 (Android 4.1.2) on a Samsung Captivate.

[More info: When I choose "Open in browser" it does open in the browser. But it still doesn't open in the Google Drive app.]

7 Answers 7


After months of mysery, I found the solution: go to docs app (instead of the drive app): if it says you need an update you are lucky as this solved my problem.

  • thx @user226449, error gone after updating DriveApp from playStore. Sep 3, 2019 at 5:18

Google Docs requires an active Internet connection, when that error happens try testing whether you can access Internet on the browser.

You can alternatively make a document available offline in the preview document screen, you still won't be able to edit it but it will be still be readable.


Go to the following link being signed in with your google account:


Then, Turn on the less secure apps and your are good to go.

  • Of course they say no connection instead of saying that you're on cellular.
    – Allison
    Apr 2, 2017 at 19:21

similar problem

Used to have the same problem. In my case, google drive was trying to open the document using Sheets app, but the Sheets app was allowed to access documents only via WiFi connection. Go to Sheets/Setings and uncheck "Transfer files only over Wi-Fi" checkbox. Be aware, that similar "Transfer files only over Wi-Fi" checkbox is also in Drive app, but this affects only Drive app, not the Sheets app.

In this case, go to Drive/Setings and uncheck "Transfer files only over Wi-Fi" checkbox.


In Google Play, update Google Docs. Looks like they fixed a bug causing the same error message. Worked for me on my Nexus 9 after this issue cropped up a few days ago.


Just open google drive in your apps and update it... worked for me

  • 1
    The original post (now 5 yrs old) stated the latest version of the app had been installed. Your result may have been accurate for your out-of-date installation, but this would not be instrumental to the original post.
    – wbogacz
    Jan 14, 2019 at 22:19

I looked at each of the earlier suggestions, and they each were either irrelevant for me or did not work.

Luckily, what worked for me on my Pixel 3 running Android 12 was simply to restart the device.

Then I was once again able to open the single problematic Google Doc.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .