1

I have a Nexus 7 updated to Jelly Bean 4.2.2, with all apps updated. Chrome is version 28.0.1500.94.

I navigated to

http://diablo.incgamers.com/blog/comments/diablo-3-podcast-102-public-game-leeches-economics-and-hardcore-dh-follies

in Chrome and long-clicked the "Download" hyperlink located below the video. This is a link to a .MP3 file (audio podcast). A short message appeared, indicating that the download had started.

However, no indicator appeared in the notification bar at the top and nothing is present in "Apps, Downloads", either when the download starts or a while afterwards.

I looked in the Downloads folder via Rhythm Software's "File Manager". The file appeared there for a short while, but vanished soon afterwards; it vanished long before it would have finished downloading.

Neither uninstalling "File Manager" nor restarting the tablet solved the problem.

Single-clicking the "Download" link causes Chrome to start playing the file, which is not what I want; I want to download the .MP3 file.

II only have a few other apps installed, which are not download/file manager apps.

  • There is a downloads app that should contain your file. – TronicZomB Jul 23 '13 at 17:42
  • No, as I indicated, "Apps, Downoads" remains empty, immediately after starting the download and after the file vanishes from the Downloads folder. – SabreWolfy Jul 23 '13 at 17:43
  • 1
    Ahh... that is odd...? Do you have a link to the page you could post so others could try to reproduce the problem? – TronicZomB Jul 23 '13 at 17:44
  • Sure; I'll update the question. – SabreWolfy Jul 23 '13 at 17:46
  • I wasn't able to get anything to download. Have you downloaded videos from this site before on Android? – TronicZomB Jul 23 '13 at 17:52
2

I tried to download the link using Chrome for Android SEVERAL times, but it always disappears. Like I've been telling myself before, Android for Chrome is not mature enough and lacking in (so many) features.

I would suggest installing a 3rd-party browser like Dolphin or Boat, which are both highly-customizable. I downloaded the MP3 file successfully using Boat (which is my main browser), and it appears in my Download folder.

1

I solved this by installing Opera Classic 12.1. Single-clicking the "Download" link prompted me to open the file via Google Music or via Opera. Selecting Opera started the file downloading via Opera's built-in download manager.

Quite a fail for Chrome :(

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.