1

I picked up a DROID R2-D2 from a coworker who has given up on the device. Knowing I like to tinker with these things, she offered me the phone in whatever condition I can muster from it.

A few weeks ago, she dropped it into some water and from that point on, the android OS will no longer boot. The bootloader screen comes up when powered on (without forcing this mode using the hardware volume buttons), but that's as far as it goes. I don't believe this is a boot-loop, as the phone does not automatically reset itself, but I'm somewhat new to the terminology. I don't believe this question is quite a duplicate of this one, as the screens I am able to access are different.

I also have a DROID X (similar question for this model), but for those unfamiliar, the bootloader presented using the volume-button-on-boot method does not produce the same screen. on the X, there are actual options, such as loading fastboot, etc. With the 2/R2-D2, there are no options, just "OK to program". I am not sure if the bootloader is unlocked or not. The working D2 is in stock condition, and the bootloader menu is minimal as compared to that of the X, and the non-working bootloader is identical. If the stock condition is locked, then I assume that this is the case.

I can force recovery mode (holding the keyboard 'x' while booting), but the options there do not help.

From the bootloader screen, this is what I see:

Always this header:

Bootloader
D2.37

if battery is charged:

Battery OK
OK to Program

if battery is depleted (I think, the batt's full at the moment and my memory may be off):

Battery low
Unable to program

if no USB connected:

Connect USB
Data Cable

if USB connected (to PC or straight power):

Transfer Mode:
USB

From the recovery screen (after loading the ! image and getting to the actual menu by pressing both the volume up and down buttons at the same time), this is what I see:

Android system recovery <3e>

Android system recovery utility

reboot system now
apply update from sdcard
wipe data/factory reset
wipe cache partition

Of the above options, I have tried all, but I know the sdcard option was done incorrectly, as I am not sure which files are required for this update. The other options, which 'worked' resulted in no change in the boot behavior.

The phone is detected by my Windows 7 machine. i.e. When I plug the device into the PC, Windows detects the hardware and recognizes the R2-D2 as being the same (no new drivers required) as the Droid 2, and I can see it in my list of devices in My Computer. However, I can't run any debug functions on it. i.e. The D2 (essentially the same phone, same hardware, drivers, etc.) that I regularly connect to my PC to test my own programmed apps, and ADB works flawlessly. Any attempt to debug the device results in the device not being found by adb. While in either the bootloader or in Recovery Mode, the R2-D2 cannot be detected by adb devices. If I plug in the functional D2, adb immediately is able to display the device ID.

Also tried to see if fastboot would detect the device, but it did neither at the bootloader, nor in recovery mode.

I downloaded a series of .sbf files from various sources (this being the only one I can find at the moment), and reflashed using RSDLite. I am new to this and so I used numerous walkthroughs from the web to get me this far. I am somewhat confident that I've learned how to flash properly, since some of the attempts failed and caused the bootloader to fail, but a few of them at least got me back to the same 'working' condition the phone was in when I picked it up.

At this point, I don't care if the phone is rooted or not; I don't care if I have a custom or stock ROM loaded; I don't care if the OS is buggy once running. I would just like to be able to get the phone to boot at all. The original owner has since picked up a replacement from Verizon, so worst-case scenario (the phone is a brick) is not the end of the world.

Especially given the fact that I have a nearly identical phone to work with, is there some way I can rip the .imgs from the working model and load it onto the broken one? Is there a step in the .sbf reload that I could be doing incorrectly? Are there any other tips or sources to help me get this phone up and running again?

  • Can you clarify your question a bit more, it seems contradicting - the phone is detected by Win7 (how? What ROM?), yet in bootloader or recovery adb devices does not "see it"? Is the bootloader unlocked i.e. S-OFF? – t0mm13b Jul 23 '13 at 20:45
  • @t0mm13b I've added some clarification to the question, but to summarize: The device is detected by the Win OS, but not by adb. I do not know if the bootloader is locked or not, nor how to tell. – Gaffi Jul 23 '13 at 21:08
1

Ok, when in bootloader - the binary app on Windows/Linux etc, fastboot should detect it fastboot devices, but in recovery, presumably that is a stock recovery for said devices, i.e. not CWM, TWRP etc.

So no adb running in the stock recovery, which is further implying, that boot loader is locked! Had it being unlocked, it would make things easier!

However, as am not familiar with the device, it might be worth your while to read this thread, (but do not act on it either as by the sound of it, you are not fully certain yet). Other than that, will leave it at that and wait until someone who is in the know with said device will respond. My answer is more generic.

  • Ok, thanks. I'll have a go at fastboot to see how far I can get there and post an update. – Gaffi Jul 23 '13 at 21:18
  • Also, with regard to that link, it applies to Droid 2 Global (D2G) with a SIM card. I don't know how much it matters, but the D2/R2D2 does not use SIM cards, so at least the first few steps won't work, and I fear that trying the latter steps will be more problematic. – Gaffi Jul 23 '13 at 21:24
  • Updating question, but fastboot also detected nothing. – Gaffi Jul 23 '13 at 22:32
  • Hmmm... In short, I think, said device is hosed, nothing with fastboot/adb would do, however, the alternative option is to approach someone who has JTAG equipment that will restore it back to factory state. – t0mm13b Jul 23 '13 at 22:42
  • Had a suspicion... Thanks for the help, though! – Gaffi Jul 24 '13 at 0:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.