2

I am using an original RAZR that is partitioned using Safestrap running stock 4.1 on one partition and CM10.1 on the other.

My problem is the internal storage (internal SD card I believe) partition running CM10.1 has a corrupt file system and I am having trouble running a check and repair. The internal storage always shows 0.0b available and no files can be saved to that disk space. The OS restores to default on every reboot, I'm guessing the config files are failing to save when I get through the setup.

Troubleshooting steps/questions so far...

  • Using Safestrap I have tried to wipe the system and all caches, then reinstall CM10.1 but no luck. The version I have of SS does not provide a file system check.
  • I can connect using shell and ADB, just not sure exactly what commands to run from there. Specifically how do I find out what file system to mount and how do I type that out as an argument?

Do I use the fsck_msdos program that I have available in the /system/xbin folder? If so how do I find the file system information to complete the syntax for running the fsck?

If fsck is the correct method to repair where do I run it from? Stock or CM installation? ADB shell or terminal from a running droid OS?

1
  • Community bump prevention: this question was closed because the question seems to have been abandoned (OP hasn't visited the network for more than 5 years, and no answers have score above 0). If anyone can evaluate the existing answers, feel free to vote accordingly and reopen the question (or mod-flag the question requesting for reopening). For anyone else having the same issue, please post a new question and refer to this question as additional context.
    – Andrew T.
    Commented Mar 23 at 10:29

1 Answer 1

0

I once tried to Format my microsd card in my razr with a safestrapped rom. My phone rebooted and I ended up having to reinstall my rom. buy a microsd card reader and format with your pc. If you have a friend that has a digital camera, you could ask them to format it for you. You would need a microsd to sdcard converter tho.

Not the answer you're looking for? Browse other questions tagged .