I am at my wit's end here trying to debug using a new LG Nexus 4 developer phone. Debugging is enabled on the phone, and the USB driver from the Android SDK is installed. When I try to run in Eclipse I get a message that says 'No compatible targets were found'.

I have previously used a Samsung Nexus S developer phone, and a Nexus 10 tablet with the USB driver from the Android SDK and it was not a problem. I have also debugged using my Samsung Galaxy S4 using the drivers from Samsung.

I plug in the Nexus 4, and go to Device Manager. In Device Manager, the device is listed as Android Phone > Android Composite ADB Interface. I right-click and select 'Update Driver Software...', then 'Browse my computer for driver software'. I then point it to the '\sdk\extras\google\usb_driver' folder of my Eclipse/Android SDK install, but I am notified that 'The best driver software for your device is already installed'.

I have tried uninstalling the driver, but as soon as I plug the phone back in, my computer automatically installs the driver, and when I go back in to Device Manager to 'Update Driver Software...', I am again told that 'The best driver software for your device is already installed'. And yet still, even after rebooting both my PC and the phone, when I try to run in Eclipse I am still notified that 'No compatible targets were found'.

Any ideas? This device is completely useless to me unless I can get it to debug from Eclipse. A co-worker was able to get it to work just fine on his PC, and we have the exact same PC specs. Please help!

  • Perhaps anecdotal, but I was debugging my Nexus 4 fine until I installed the Samsung drivers for the GS3 and Note 10.1. Removing those drivers (with Driver Sweeper) fixed my situation.
    – mawcsco
    Jul 26, 2013 at 16:33
  • @mawcsco I just uninstalled drivers for all my devices, rebooted my PC and the Nexus 4, tried it again and still doesn't recognize the device. I'll try Driver Sweeper, but am not familiar with it, or how to target the Google USB driver that comes with the Android SDK for uninstalling. Will give it a shot though.
    – tjc59
    Jul 26, 2013 at 16:56
  • @mawcsco I tried following the instructions for Driver Sweeper, but I couldn't figure it out. I uninstalled all the drivers normally, then rebooted in Safe Mode and ran Driver Sweeper, but didn't see any Android or USB drivers listed, I only see drivers for things like display and sound and mouse.
    – tjc59
    Jul 26, 2013 at 18:30
  • Sounds like you already got them with the regular uninstall. Incidentally, for me it was the Samsung drivers that caused problems. Like I said, this is an anecdotal case (which is why I didn't provide an answer).
    – mawcsco
    Jul 26, 2013 at 18:48

3 Answers 3


Couple of suggestinos that might work:

  • First, try to update your Android SDK with the Android SDK Manager. Sometimes, due to a old version, newer phones are not recognized.
  • I'm assuming you are using Windows. Wich version? x86 or x64? When you go to Device Manager and see Android Phone > Android Composite ADB Interface, does it have a yellow admiration mark? If yes, the the drivers are not installed correctly.
  • This might be a bit trivial, but have you tryed to reboot your PC and your phone?
  • Also, what minSDK version do you have in your application set, and what version does your Nexus 4 have?
  • 1) Already tried updating everything that had updates available (including the Google USB driver). 2) Windows 7, 64-bit. There is no yellow mark in Device Manager. 3) Have tried rebooting both (was in my OP). 4) minSdkVersion="9" targetSdkVersion="17". How do I see what version the Nexus 4 has?
    – tjc59
    Jul 26, 2013 at 16:14
  • 2
    It is better to post a comment on the question soliciting additional information instead of having an answer filled with questions! (just saying) ;)
    – Zuul
    Jul 26, 2013 at 16:15
  • @tjc59 In your phone, go to settings, Phone information (the last entry), and you should see there Adroid Version. My Nexus 4 is in 4.2.2 right now. Jul 26, 2013 at 17:18
  • Mine is 4.2.2 also. According to the Android developers website, targetSdkVersion="17" should be compatible with Android 4.2.2.
    – tjc59
    Jul 26, 2013 at 17:49
  • @tjc59 connect your phone to the PC, and from a consolo try to run adb devices. Post the output here, please Jul 26, 2013 at 20:34

use a usb 2.0 port. sometimes usb 3.0 screws up with adb

  • As far as I can tell, all my PC's USB ports are 3.0, so not sure how this is going to be possible...
    – tjc59
    Jul 26, 2013 at 16:58
  • then you have to use windows' default usb 3.0 drivers for it to work (as compared to maybe a proprietary one??) Jul 28, 2013 at 6:05
  • Sorry, but I don't know what you are talking about. As I said in my OP, a co-worker has the exact same PC (model/specs) as I do, and he had no issues getting the Nexus 4 to work with Eclipse.
    – tjc59
    Jul 29, 2013 at 13:13
  • Normally USB 3.0 comes with drivers. There's the default which Windows installs over auto-update, then there's the one that came with your laptop/mobo. Mine worked after using the default Windows driver. Jul 30, 2013 at 1:42
  • I searched for "Windows 7 USB 3.0 driver" and got no results from Microsoft, so I'm still not sure where this default Windows USB driver is. And all my Windows Updates are installed, so not sure what else I can do here regarding your suggestions.
    – tjc59
    Jul 30, 2013 at 13:23

It could be that MTP interferes with ADB/USB-Debugging:

In my case, MTP (Media Transfer Protocol) was enabled. So I disabled it in storage settings (see: Settings→Connections→USB Connection Mode). Everything works smooth now.

  • 1
    @Izzy, this could be an answer. After all, defining how the phone connects to the computer (using MPT or PTP) may affect whether USB debugging would work or not.
    – Stephen S
    Mar 5, 2014 at 14:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .