20

I'm running Android 4.2.2 on my Nexus 4. It is rooted, and I have ClockworkMod recovery installed, but rom and kernel are stock. I received the OTA update to 4.3, and would like to install it, but it failed. (With a message that CWM couldn't verify a signature. I remember that the previous OTA worked, and I think I had to re-root, but that was easy.)

How can I get the stock 4.3 update on my phone, while keeping root and CWM, and especially keeping all my data? Step-by-step instructions would be great.

Also, I'm curious, what is the technical reason that the update doesn't install?


Update: I found some instructions here, however they didn't work for me. I get the following error from CWM while applying update.zip:

Installing: /sdcard/0/update.zip
Finding update package...
Opening update package...
Installing update...

Warning no file_contextsVerifying current system...

assert failed: apply_patch_check("/system/bin/app_process", "76c3a9a7a6d400a9ff3e4db391327daa33aa0663", "2a221441bf06f2618aa6c35ae0cade13bd4f6e1b")
E:Error in /sdcard/0/update.zip
(Status 7)
Installation aborted.

Update 2: I forgot that I tried out Xposed some time ago. Apparently this modified /system/bin/app_process. I removed it by starting Xposed Installer, and then selecting "Uninstall (restore app_process)" and (probably not neccessary), "Clean up (complete removal of the framework)". I did one complete reboot, and then rebooted into recovery mode to continue the update. But now it hangs because "build.prop" is modified (don't remember changing that). I wonder if there is a way to just flash the new OS files (not patches), overwriting any modifications, but keeping all settings and user files...

17

It sounds like the "/system/bin/app_process" has been modified and so it doesn't match the signature required. There are 2 ways to fix this, either get a copy of the stock file from another phone/rom or flash the factory image for 4.3

Edit: After reading "update 2" it sounds like you want the factory image option detailed below.

AndroidPolice has a step by step guide here. I've duplicated the steps in case that page dies:

Download the full occam factory image, which includes the full system, bootloader, recovery, kernel (boot.img), and radio. It's a clean slate for these components - they'll flash cleanly over anything you have now.

Instead of using the bundled script called flash-all, you will unpack the tgz (tar/gz) archive, and then the zip contained within as well. This will put all the components into one folder:

Follow the excellent guide over here and make sure to omit step D10, which overwrites userdata. Here are the commands you will be executing, for reference:

  1. adb reboot bootloader
  2. fastboot flash bootloader bootloader*.img
  3. fastboot reboot-bootloader
  4. fastboot flash radio radio-mako-m9615a-cefwmazm-2.0.1700.84.img
  5. fastboot reboot-bootloader
  6. fastboot flash system system.img
  7. fastboot flash boot boot.img
  8. fastboot format cache
  9. fastboot reboot

Note: Instead of unpacking the image*.zip and flashing system and boot manually, you can actually do fastboot update image*.zip - this won't delete data (you would pass a -w flag if you wanted that to happen), but it will re-flash recovery back to stock if you were running a custom one. You can then flash it back, or just use the commands above instead. Either way, the result will be the same.

You will then need to re-root (there is no way to go from 4.2.2 to 4.3 keeping root at the moment) by following the steps in this thread (I won't link to the file itself as it is being updated as/when issues are found.).

  • I don't see any boot.img file for the 4.3 update for the Nexus 4 that I downloaded. I have the bootloader.img, image.zip, and radio.img. Where's the boot.img? – anon58192932 Aug 17 '13 at 20:11
  • 1
    You need to unzip the image.zip as well. the boot.img and system.img are in there. – bmdixon Aug 20 '13 at 9:48
  • Gave up on trying to flash these manually after first boot was getting stuck. I extracted the factory image to my ADB directory and ran "flash-all.bat" and it booted right up first time after that. The flash-all.bat does a bit more than the above procedure. – anon58192932 Aug 30 '13 at 3:54
2

I ran into the same problem. I ended up downloading the stock 4.2.2, flashing that (also un-rooting my phone), then installing the OTA update.

  • 1
    Do you know where one can download the stock OS (Assuming there is a legal download)? Also, does flashing preserve your data? – jdm Jul 27 '13 at 10:05
  • 1
    @jdm Oficial stock roms from Google: developers.google.com/android/nexus/images#occamjwr66v – Cobold Jul 27 '13 at 10:22
  • I don't think your data will be preserved. And yes grab the images from the official Google page. It looks like 4.3 is there now. Also, here is a link to a guide to flashing 4.3: bit.ly/16aTnvY That guide states that you won't lose data. – user38304 Jul 27 '13 at 10:31
  • OTA is able to preserve your user data. I don't believe that flashing the factory image is able to preserve all your user data. – anon58192932 Aug 17 '13 at 20:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.