1

My Samsung Galaxy S GT-i9000 rebooted unexpectedly and when it came back up all my app symbols showed a grayed out android image with SD written in the bottom right corner.

All my music was gone too. I went to check under "SD Card and Phone Storage" and under "Storage Settings" it said "Mount SD Card". I clicked on "Mount SD Card" and it turned into "Mounting.. Mount in progress" but nothing happens (15min).

I tried powering off the phone and removing the battery and SD card, putting everything back and powering up again, but no success.

I also tried a Factory Reset, the SD Card is not recognized.

I inserted the SD card into my friends Samsung Galaxy S2 and it appeared on his phone and he could copy pictures and music to it, but on my i9000 the card does not appear.

What do you suggest i do?

  • Have you tried hitting Mount SD card in settings? – user24200 Jul 28 '13 at 15:27
  • @jeffreylin_ His question states he did (second paragraph). – Izzy Jul 28 '13 at 19:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.