1

I have rooted phone with Android 4.0 and laptop with Windows 8. I have made wirtual hotspot with:

netsh wlan set hostednetwork mode=allow name=** key=**
netsh wlan start hostednetwork

Than I shared my default connection to newly created, phone have found this network, but couldn't connect to it (claimed 'avoided poor internet connection'). After googling around I figured out that I should set static IP, and phone finally connected to network, but without working internet. I have absolutely no idea what to do next.

Here is output of ipconfig /all: (PC internet connection - Ethernet adapter Local Area Connection 2; hotspot connection - Wireless LAN adapter Local Area Connection* 12)
http://paste.ubuntu.com/5925983/

Android device configuration:

IP - 169.254.179.101
Gateway - 169.254.179.10
Network prefix length - 16
DNS 1 - 169.254.179.10
DNS 2 - 8.8.4.4

UPD: Wifi analyser on Android side shows

Server IP: 0.0.0.0
  • 1
    This question appears to be off-topic because it is more about Windows than Android. – roxan Jul 29 '13 at 18:03
  • @roxan Actually, I am pretty sure that the problem lies in wrong configuration of static IP on Android side, so I suppose, it is not. – Kriattiffer Jul 29 '13 at 18:54
  • I'd say that this is okay here. Did you look through the other wifi-hotspot questions we have here? – ale Jul 29 '13 at 19:29
  • Just for clarification: Is the created hotspot by any chance an ad-hoc network -- or is it truly "infrastructure" mode? Because if it's ad-hoc, it's not supported out-of-the-box by Android. – Izzy Jul 29 '13 at 19:58
  • Are you sure the Windows box is set up to act as a router? That's not the usual configuration, so if you haven't done anything to enable that on your laptop, you won't be able to access its internet connection from other devices via W-Fi. – Dan Hulme Jul 29 '13 at 22:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.