I've got a Droid X, running Android 2.3.4 and System version 4.5.621.MB810.Verizon.en.US.
Just recently, Google Play stopped working.

Whenever I open Google Play, it immediately displays:

No connection

YouTube also doesn't work - nothing will load. It says:

There was a problem connecting to the network

The Retry button doesn't fix anything.

I've already tried the following:

  • Set Date/Time to Automatic (network-provided)
  • Stop + Clear Cache for Google Play and Play Service
  • Reboot Phone
  • Toggle Airplane Mode
  • Toggle Wi-Fi

The phone's internet is working fine - I can browse the web and everything, but the Play Store and YouTube don't work. I have Application-Specific Passwords enabled, and my phone is signed in via one.

I have no Data connection, but the phone is connected to Wi-Fi.

  • Are you able to reach other Google services?
    – ale
    Commented Jul 30, 2013 at 15:22
  • @AlEverett No.. just tested now, and I can't seem to retrieve any new Gmails, GrooVe IP doesn't ever sign in, and viewing my google Account in the System Accounts shows a little bar at the bottom of the screen saying Sync is currently experiencing problems. It will be back shortly. (with an error icon next to "Sync People Details.) However, I can do anything I want through the browser. No issues on that end. It seems to be just the Google Apps. Commented Jul 30, 2013 at 15:30
  • Bummer. I found this question but it has no solution (although it does link to some similar questions). I'm going to guess and say it's a local network thing. How long has it been going on?
    – ale
    Commented Jul 30, 2013 at 15:35
  • 1
    ...maybe a few days? I just solved the problem, though. I don't know what exactly the issue was, but it's fixed now. I'll post what I did in a sec. Commented Jul 30, 2013 at 15:38
  • Aw, poop. Changing the password only fixed it temporarily. Back to the drawing board.. Commented Jul 31, 2013 at 2:51

13 Answers 13


First thing to take a look at in cases like that is the color of your connectivity icons in the status bar. Any color other than green (< Android 4.0) or blue (Android 4.0 and up) indicate trouble with your connection to Google's servers.

Possible causes vary, and might include (but are not restricted to) the following:

  • some (temporary) routing problem: If you've already got some terminal app installed on your device, you can check this with the ping command on some of the Google servers, e.g. ping chatenabled.mail.google.com. No response, or huge packet loss would confirm this cause. If you wonder why it might work on a different device at the same time: they might use different local mirrors.
  • some (temporary) "outage" of Google Services: If your internet is otherwise working, or you have some working internet available on another machine, you should be able to verify this with Google's Dashboard. Any outages/unavailibilities should be indicated here (unless they just started whortly and the Dashboard was not yet updated).
  • trouble with authentication: These should usually manifest in frequent popups asking you to place your Google credentials. You could of course try to solve these by deleting the Google account from your device (or by revoking its access codes to force it requesting new ones), and re-creating it – but I wouldn't do that immediately. In many cases, this solved itself after a while (or after switching to a different network, in my case).

As the case of the OP proves: most times this requires nothing but patience, until the issue "resolves itself".

  • Running Gingerbread, the icons are blue. Sometimes, Android will disregard the wifi connection if I let it go to sleep, in which case the icons will be grey for a few seconds upon wake (even though I set it never to disable Wi-Fi...) Commented Aug 24, 2013 at 21:46
  • HOWEVER, I have GrooVe IP set up with its own Application-Specific Password, and it works just fine. Commented Aug 24, 2013 at 21:46
  • You seem to have had one of the first two issues. Like with my experience (third variant), these often seem to resolve without any help from the user's end, so all that's left to us is to wait it out. I was already short to factory-reset, when the spooky stuff stopped all of a sudden when I'd left my WiFi coverage and mobile data kicked in (other devices in the same WiFi had no trouble at all, and that one device neither when it returned). Spooky stuff, as said...
    – Izzy
    Commented Aug 24, 2013 at 22:29
  • Yeah, sometimes apps don't want to work with Wifi.. The built-in Skype doesn't even work without a (mobile) data connection. But you'd think the built-in Google Account integration would have that fixed.. evidently not. :/ Commented Aug 24, 2013 at 22:33

My son and I both had the same problem on multiple devices. So I restarted my router (not reset, only restarted it), then it worked just fine. It's a router problem.

My Google Play Services were working on mobile data, just not my WiFi. It was going on for a couple days and we restarted the router. Now it works fine.


I have had a similar problem earlier. Try connecting other devices (Android devices) via the Wi-fi or any other Smartphone devices.

This generally happens when the Wi-fi connection hasn't been setup properly.

  • No, the Wi-Fi connection is set up perfectly. I'm not even doing anything like using a proxy. The web browser can connect, I can log in to my Google Account and get a new ASP from within the browser, and other apps that use Google Accounts never malfunction - that is, when set up with their own ASP. If I tell them to use the system-wide OAuth signin, they just go down with the phone. Commented Aug 24, 2013 at 21:48

First delete data for Google Play.

Then open a browser on your Android phone. and go to: http://www.androidpolice.com/2013/12/05/download-latest-google-play-store-4-5-10-with-shared-play-store-activity-iap-indicators-and-more/

(or simply search: android police latest google play)

Download and install Google Play.


Same thing happened with me: Playstore stopped working and google account won't sync people details.

Here's what i did and thanks God its fixed now:

  1. first of all try syncing you google account in settings
  2. if it doesn't sync properly:
    1. reboot your device
    2. turn off WiFi (in my case the Playstore didn't work in WiFi but worked in data connection)
    3. turn on your data connection
    4. clear cached data of Google related apps
    5. now in sync folder in its menu choose sync all (it would hopefully sync properly now)
  3. open your Playstore (it should be working by now)
  4. turn on your WiFi and than try using playstore with WiFi
  5. then if it does work turn off your data connection and enjoy using WiFi

I had same issue wIth my Asus padfone 2. No connection to Google play. YouTube and Gmail worked. Connection was tried with WiFi and mobile data, neither worked. Tried all the common answers, like emptied caches for play and other Google software. Did a factory reset a few times when nothing worked. Finally took phone to service and they installed the motherboard software again. Same version as before. This fixed the issue.


Okay! So I got a perfect solution first root your phone by finding some apk file like towelroot in any browser and after rooting download hosts editor pro(apk free)and there is 1 host there click on that host and press toggle u can see a “#” so that means u can now sign in with no problems I hope u find this helpful.it worked for me.after this if u want to uninstall root use super su


Try this, (your mobile should be rooted first)

  1. Install Root Explorer
  2. Open it and grant SU permission to the app
  3. Click folder /system
  4. Click folder /etc
  5. You will be able to see a file named hosts (no extension).
  6. Delete the file. Don't worry, it won't affect your ROM as well as your device.
  7. Reboot the device.

Now, try to login to Gmail again on your device.


I had a customer with the issue. He had disabled all google applications to save memory causing it to google play not to work.. Hope this helps


just go to settings, app manager, find play store, and clear its data. it should work. one thing, you just need to set again the preferences of your playstore. ;)


Try flashing gapps on your phone . hope this helps


Try "Wipe cache partition" and "Wipe dalvik cache" in recovery mode.

  • why do we need to wipe all apps cache? Or just clear data & cache for play store app alone?
    – Akhil
    Commented May 2, 2014 at 3:40

Go to app menu, delete data for Google Play services, and retry.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .