6

I've got a Nexus 4 (but this question relates to all eligible devices) currently running Android 4.2. However Android 4.3 was announced a few days ago.

  • I've run Check for Updates
  • I've followed the tips to checkin
  • I've done the trick to "Force Stop" the Google Service Framework app and then pressed "Clear Cache".

But none of this seems to be doing anything, and I'm still running an "Up to date" OS with 4.2.2.

Is this a carrier issue? Could it be because I'm not on one of the BIG THREE carriers in Canada (Rogers, Telus, Bell), but instead I'm on Virgin Mobile?


footnotes:

†: *#*#2432546#*#* or *#*#checkin#*#*

5
  • Perhaps Virgin Mobile are vetting the OTA?
    – t0mm13b
    Jul 30 '13 at 17:02
  • When my WiFi Xoom was still officially supported, it took several (sometimes 30+) attempts at Force Stopping and Cache Clearing of Google Service Framework before Check For Updates would recognize I had an update.
    – Dylan Yaga
    Jul 30 '13 at 17:17
  • From what I've read the force-stop of the Google Services Framework doesn't work any more.
    – ale
    Jul 30 '13 at 17:44
  • For what it's worth, I have a WiFi Nexus 7 (so, no carrier encumbrance) and I didn't get the update until yesterday. They just seem to be rolling it out fairly slowly.
    – ale
    Jul 30 '13 at 17:45
  • @AlEverett Same and I only got mine this morning. Still haven't received it for my Nexus 4. EDIT: Just the tried the answer to this and it worked for my Nexus 4, got 4.3 now.
    – Peanut
    Jul 30 '13 at 17:46
6

So I tried to "Clear Data", instead of just "Clear Cache" in the Google Service Framework (and Forced Stop).

I then ran the checkin again (Dial *#*#2432546#*#* in the phone app), and now I'm being shown the new Android 4.3 System Update.

4
  • 1
    Just tried this on my Nexus 4 and it worked (UK), I also force stopped GSF.
    – Peanut
    Jul 30 '13 at 17:47
  • 1
    Worked for me too (China)
    – Erowlin
    Jul 31 '13 at 9:13
  • Worth noting that this can cause issues with the play store, if it does remove your primary account and re-add it. Aug 1 '13 at 6:51
  • Yes this seems to have removed my device from my Play Store devices. I've tried @jamesakadamingo's fix, but my device isn't there. Truthfully though, I'm just happy I have the latest version... Now trying the same thing with Keylime... er, KitKat. Nov 13 '13 at 21:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.