I seem to have somehow developed an invisible exchange account on my rooted (but otherwise stock) 4.1.2 AT&T HTC One. I don't know at what level to attack this problem -- is it a Sense issue or an Android issue? What app or data should I delete / uninstall or clear?

If I go to Settings -> Accounts & sync -> under the "Manage Accounts" area there is no Exchange ActiveSync account even listed.

If I try to add an "Exchange ActiveSync" account I get the Error message in a popup box that says "You have already set up this Exchange account." Googling for that message or searching for it on xda did not yield anything helpful.

I'm not sure if this developed at some point from a Nandroid restore or what...

Does anyone know how to delete this invisible Exchange account that it says I have already set up? I can't see the account anywhere to delete it, but it's data must exist somewhere inside "Accounts & sync" and so it thinks I have already set it up... I'd like to delete it for real and then re-add it.

UPDATE #1: I don't use any Exchange services (Outlook Web, nor MS Outlook).


6 Answers 6


I think I have encountered a similar issue before. Not sure how I fixed it, but

  • see if you have a Device Administrator for Exchange. In the Samsung Galaxy S4, it's in Settings > More > Security > Device Administrators. Uncheck / Remove it there, do a restart, and see if that helps.
  • or: Go to your application manager, and swipe to the ALL section. Then look for the Email app. Click that and do a Clear data and/or Clear cache. Also, look for the Exchange services app, and do the same. Restart, and see if that helps.

Based on Asker's feedback, the second approach fixed the problem. He also cleared the GMail app, although it's not necessary.

  • Thanks for the idea... but not a help in this case. I went into "Device Administrators" on my HTC One, but there are no accounts listed in there. Jul 31, 2013 at 20:27
  • I'm thinking that the only way to fix this is to do a factory reset and then reinstall all my user apps (being careful not to restore any system settings). So I will probably have to do that, but if anyone does discover the answer please post. Jul 31, 2013 at 20:28
  • second bullet point also fixed the problem for me on my LG Optimus F3. Thanks a ton! Feb 17, 2014 at 15:13
  • The initial suggestion is what I was looking for to delete an account that couldn't be deleted. On Lollipop, it's the Gmail app that's listed as the device administrator, since the Email app doesn't exist anymore. May 28, 2015 at 15:41
  • Deactivating Device Administrator for email worked for me. Had to pause my Twilight app (brightness app) to confirm action on dialog. Thanks!
    – SJR
    Dec 2, 2017 at 8:51

Here's how I fixed this on my HTC One 1. Open Settings -> Apps 2. Find the Mail application in the list of all Applications 3. Press the "Clear Data" button 4. Reboot the phone.

After doing this I was able to add my Exchange account

  • Thanks. Clear Cache didn't work. Feb 11, 2019 at 18:38

Under Android 7.1.1. I had deleted my work Exchange account because I was trying to troubleshoot why that account wasn't syncing parts of my calendar. I went to accounts and deleted it, then when I tried to recreate it I got the same dialog, wouldn't let me set it up with the username on my Excahnge account, said it already existed.

I restarted, deleted all my gmail accounts as well to no avail. Tried wiping the cache in the fastboot menu, same thing. I finally ended up going to Settings/Apps/gmail, but there is no button to clear data, so I disabled gmail, and it asked me if I wanted to go back to the original installed gmail. I confirmed that, restarted, and I was finally able to add that Exchange account. Hopefully sometime soon it will update gmail, but either way it is working.


I developed the "Duplicate Account", "You're already using this username..." problem after using AkrutoSync in multiple locations with the same laptop over WiFi. I was using different routers at each location of course, which, provided different IP address. Seeking a better way to change locations/servers/IP address, I experimented with the server IP address settings and the result was that I locked an exchange account into a file and could not delete the account. (Nexus 5X on Oreo 8.1.0) I cleared data and cache for both my gmail and my Google Inbox app, then rebooted and the problem was solved. Thanks.


I had this problem on a Xiaomi Poco X3 just now. I had removed the 365 exchange email account from gmail client to enable 2 factor authentication then when I added the account back in gmail said it already existed and would not let me. After trying the above solutions and them not working for me I realised that my google account on the poco x3 used the same email address as my 365 exchange email account. I removed my google account credentials first then re-added my 365 exchange account in gmail which it accepted this time and then once the emails were working I added back my google account credentials with no problems.

It worked for me.


Go into the Mail App. Go to Account Settings.... Delete account. Keep deleting until the exchange account is deleted. Then re-add the accounts.

Works like a charm!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .