1

I have a ZTE phone, that I installed a CWM recovery. After that I tried to install a custom rom.... After many problems I managed to flash the official rom from ZTE site by using their online update utility (the phone was in FTM mode).

After doing this, my phone became network locked. What can I do to unlock it ?

The funny thing is that I bought the phone from Greece without any sim lock, and installed a Turkish custom rom and then this thing happened.

This is the phone: http://www.ztedevices.com/support/smart_phone/8c503c22-fc52-4935-bb1e-3ce308bece6f.html?type=software

Now it is locked to Turkcell

Any ideas?

Edit (Further details furnished as per comments)

  • 1
    Unfortunately, it does look this way, that by flashing the official ROM, the device got its SIM re-locked and locked into the network. You need to go to a shop that specialises in network unlocking or hunt around on internet. You did point out you had problems with flashing, was the CWM official for that said Zte device? (Btw, what is the actual Zte device name? - please re-edit to include that information and Android version) – t0mm13b Jul 31 '13 at 12:19
  • The device that I have is a ZTE Black ICE (the greek version). The Turkcell maxiplus 5 is the turkish equivalent. It is, baseband version P752TB01. Android version is 4.0.4 The CWM recovery was not the official one for the device, but it was on that worked fine, since I took a NANDROID and also flashed root. – malcolm the4 Jul 31 '13 at 13:39
  • Could you suggest where to find someone to unlock the device? are people on ebay luckily to do it ? thanx! – malcolm the4 Jul 31 '13 at 13:39
  • Wait - are you telling me, CWM was already on the device that you bought it from? As for suggesting where to find someone to unlock, you'll have to figure it out by googling to see the cheapest available... – t0mm13b Jul 31 '13 at 13:52
  • No, the device had it's own recovery (not CWM). I installed via ADB CWM recovery (which was not specific for my device, but it was a CWM recovery that worked fine with my device. Other users suggested using it in order to ROOT or flash a custom rom. After I flashed the custom rom, the CWM was gone. This was the biggest problem and that is the reason I tried to install the official ROM – malcolm the4 Jul 31 '13 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.