8

I need to run Google Plus, and Google Plus needs the Google Play service.

Every time I install google play service from the Google Play store it fails to install with this error:

Incompatible with other applications(s) using the same shared user ID

What could be the issue? How can I fix this?

UPDATE: I know almost nothing about android, so I dont know what ROM is, or such thing, I get my phone from local production and I guess, yes, it uses custom system, so I just know that I'm using Android Version 4.0.4. any help would be greatly appreciated.

  • Mind to add some details on your device? Which is it, what Android version is running, is it a custom ROM (and if so, which)? On a stock ROM, Google Apps should already come pre-installed. – Izzy Aug 1 '13 at 9:13
  • Google Play Service is part of your Android OS. You don't need to install it separately. If you have custom ROM and you have done some modification then mention it so that others can help. – Darshan Prajapati Aug 1 '13 at 9:17
  • Reads like your "local production" hasn't set-up the custom system correct. – Flow Sep 17 '13 at 13:26
6
+25

What is get my phone from local production?

Since you mentioned about custom system are you referring to a modded ROM like Cyanogenmod, Paranoid Android etc?

You have custom recovery in place? If so, grab the latest Google Apps from here appropriately for Android 4.0.4 aka ICS, more than likely, this version of gapps.

Reboot into Recovery, select:

  • Wipe Cache
  • Install from zip, select the gapps you downloaded
  • Then when install is done, reboot.
2

Google Play services is used to update Google apps and apps from Google Play. This component gives you access to Google Settings and helps apps speed up offline searches, provide more immerse maps, and improve performance.

If you think there is an error of your OS, you can always go for a factory reset. You shall backup your data before you proceed. This should re-install the Google Play service. And if you are NOT asked to install Google Play Services, you don't have to. It is bundled with your OS. You must simply be able to download Google+ and use it on your phone.

You can find your device info from Settings => About Phone

2

What worked for me was the suggestion I found here:

http://forum.xda-developers.com/showthread.php?t=1219029

In a nutshell:

  1. Figure out the exact formal fully-qualified package name or *.apk name for the app you're trying to install. For Google Play Services, it's com.google.android.gsf or GoogleServicesFramework.apk.
  2. Pull the /data/system/packages.xml file from the phone using adb
  3. Open the xml file in a text editor and look for the <package> xml element that describes your app, using the names from step 1.
  4. Get the value of the sharedUserId attribute for that element.
  5. Remove the entire <shared-user> xml element with the userId attribute that matches the id you found for the package.
  6. Push the modified packages.xml file back to same location on the phone using adb
  7. Wipe the dalvik cache and reboot.
  • I don't understand how people can trust other solutions like wiping cache/data. Your instruction is clear and understandable! Help me to install MX player on top from modded ROM. Thanks! – gavenkoa Jan 16 '16 at 21:39
1

I had the same problem. I uninstalled all app updates and this fixed the issue

-1

You should know this first that Google play service is required by some apps which had implemented functionality provided by google play services. Like multi player, real time multi player, leader-boards, achievements in some games ans apps.

If you are having problem in downloading it there are many possible solutions there. - Go to the application manager, remove all updates from google+ related apps. Then start play service after installing all the apps updates. This might get solved ur problem.

protected by Community Jan 31 '14 at 20:41

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.