0

I rooted my device (lenovo 2107a) and then updated new custom firmware with below instructions:

  • Downloaded new firmware into sdcard/clockworkmod
  • booted to CWM
  • selected "backup and restore" -> "advanced restore from internal sdcard"
  • and chose my custom ROM
  • Then i selected "system restore"

So i saw an error that said cannot restore and restore goes to break. now when boot my device i see a screen that wants to select country code and after select device will reboot again and i see same screen.

so i decided to restore my old backup, but even old backup restoring gives me the error that cannot restore.

i find the problem, when i open shell with this command:

adb.exe shell
$su
su
segmentation fault

the problem is that all of data in /system is read-only and i cannot even root with su. i tried everything like re-rooting device, but still i cannot shell as root.

mount cannot be run (operation not permitted)

adb.exe remount (cannot be execute)

fixsu.sh cannot be executed because has not access to /system (everything is read-only)

psneuter gives (failed to set prot mask (inappropriate ioctl for device))

is there any way to delete /system and re-upload that or something that can solve my problem?

  • If I understand correctly... You tried to install a custom ROM, but instead of choosing "Install from zip...", you choose "Advanced restore..."...? – Matthieu Harlé Aug 2 '13 at 18:36
  • yes i did, your right – user1728307 Aug 2 '13 at 18:47
0

I got a tip from XDA dev's under Android-General Developing: give the custom ROM a new name by renaming "update.zip" on the SD Card. Under CWM, pick this "update.zip" under Update setting.

This was tested with Moto Defy+ 2.3.6 stock ROM and HTC One V GSM with a Sense 5.0 custom ROM when I tried to install MIUI 5.

  • Perhaps a link to that particular thread would be nice – Sid Sep 15 '13 at 7:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.