7

I rooted my Asus Transformer Prime and tried to install a custom ROM but I managed to fail. I selected the option to wipe data from the table in the bootloader menu (accessed it via holding power button and volume down) and then I cancelled it by turning the device off because I wasn't supposed to select that. It seems this wasn't wise...

I tried to boot the device but now it's stuck saying "Asus" in the middle of the screen. If I try to power it off, it turns off but immediately it turns back on.

I can't access the bootloader menu. Fastboot nor ADB sees the device via USB.

How can I restore it?

9
  • Have you researched into this post on XDA?
    – t0mm13b
    Commented Aug 6, 2013 at 18:50
  • Thanks for linking that. I would need a device specific blob.bin file to restore my tablet using that guide. I don't have it because I didn't have intentions to brick it. Well, actually I didn't know that. Another problem is that it doesn't work with Jelly Bean.
    – MikkoP
    Commented Aug 7, 2013 at 8:40
  • 1
    This is not abrick, a brik would not display the samsung logo or respond to commands. What do you mean byt bootloader menu? you mean entering in download mode or recovery mode?
    – Mihai
    Commented Aug 7, 2013 at 8:48
  • Then what is it? I can't access the bootloader menu to enter fastboot. Android won't boot. What's wrong? (PS. It's Asus!)
    – MikkoP
    Commented Aug 7, 2013 at 8:50
  • @Rat2000 Yes, recovery, fastboot etc... Power + volume down
    – MikkoP
    Commented Aug 7, 2013 at 8:57

4 Answers 4

2

I was having the same issue as this. I was in a "recovery boot loop" and could not get to the recovery options. I did have ADB access to the device after I installed the "Naked Drivers". Once I did this I was able to see the device using the command "adb devices". The MAGIC command once I had adb access was "adb reboot bootloader" BAM! It rebooted mid bootloop and I was able to select the fastboot option. I followed all of matt95's instructions above including following the link he provided to XDA. The link at XDA explained how to get the "blob" file. It's easy, you download the current rom from ASUS and extract the blob file from it. I literally copied and pasted each command with the exception of the path to my blob file and my TF201 has been resurrected!

Good Luck!

0

It seems that you have installed the wrong recovery and your devices is semi-bricked (it's not over for him yet). You should:

1-Download the correct firmware blob from the official ASUS site 2-Boot your tablet into recovery and then type on a computer with the device connected

adb reboot bootloader

3-Your tablet should now receive fastboot commands even if it seems not on the tablet screen (on the tablet the screen seems stuck)

4-Type all these commands one by one:

fastboot erase system
fastboot erase recovery
fastboot erase userdata
fastboot erase boot
fastboot erase misc
fastboot erase cache
fastboot -i 0x0B05 flash system path/to/firmware.blob
fastboot -i 0x0B05 reboot

If these commands do fail try this 4th step again

Also, refer to this great thread on XDA

1
  • I can't boot my device into recovery. I can get into APX, but I don't have the blob file from nvflash for my system.
    – MikkoP
    Commented Jul 3, 2014 at 12:41
0

Try these instructions:

  1. Copy a recovery which supports the Android version of the ROM and put it into SD card .
  2. Boot into recovery .
  3. Install the recovery.zip
  4. Reboot recovery ( If CWM , this option is present under "Advanced") .
  5. Wipe data/factory reset
  6. Wipe cache.
  7. Install ROM zip file
  8. Reboot system.
1
  • I can't boot into recovery.
    – MikkoP
    Commented Aug 10, 2014 at 8:43
-1

You will need to download a proper firmware(ROM) for your device, possibly an identical one as of your current damaged one, then wipe data/system/cache (BUT NOT THE SD!) install the rom from recovery and done. For details contact me directly, I can help you with advices.

1
  • 1
    Yet another answer that suggests going into recovery mode. As said, I can't access the recovery menu.
    – MikkoP
    Commented Oct 29, 2014 at 16:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .