2

I am using a Galaxy Nexus LTE running Jelly Bean 4.2.2 with service from Verizon Wireless in the U.S. In Settings > Wireless & Networks > Mobile networks, I have:

  • Data enabled: on
  • Data roaming: off

I have flown to Canada twice recently. Both times, I turned my phone on to discover that I was getting new email through data roaming via a Canadian network, and was later billed accordingly. This happens despite the fact that I have Data roaming off. I have to turn Data enabled to off or go to Airplane Mode to get the phone to stop using data roaming.

Is there a way to actually disable data roaming so that I can set it and forget it?

  • Does your phone know that it is roaming when it is roaming? Usually it will say Extended 4G instead of 4G or Extended 3G instead of 3G etc. – John Aug 6 '13 at 7:20
  • There is a little "R" next to the signal bars when I am roaming. – Michael Hoffman Aug 6 '13 at 21:34
  • Do you have root? – John Aug 7 '13 at 18:11
  • No. I do have Developer Mode enabled. – Michael Hoffman Aug 8 '13 at 0:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.