1

How do I set the calendar display to the correct timezone on my Samsung Galaxy Nexus phone?

For instance, editing of a calendar entry shows 14:00 [Montreal time], but the event display time in the calendar's weekly view for the same entry is 17:00.

1

You might be aware of the common fact that the date,time,time zone set in the device settings will act as a reference/source for various apps like calender,logs,messages.So whatever be the date,time setting your settings will be reflected to all the required apps.(factory widgets,custom installed apps). So if you want the correct time to be reflected in the calender as well you need to change the source of the date,time.

Note:-Some apps like what's app have inbuilt detection methods through which the app will give you a warning in change of time when compared to the previous set time.(i.e. if there is a change in the time of app and time of device then it will give you a warning to set the correct time and date and the app will not start until and unless the time is correct)

As @geff has suggested please try changing the Time zone of the phone.

0

This is from the point of view of a Samsung Galaxy S4.

I would look at two things:

  • Timezone of phone: system settings > more > date and time > select timezone
  • Timezone of calendar: S Planner app: settings > lock timezone and settings > select timezone

I'd make sure both of them are the same. Setting them manually instead of auto might be a better configuration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.