0

I trid to install the Firefox browser on Android 2.3.6 (Gingerbread). After downloading, in installing progress, it failed with this message:

Application not installed.

I have enough memory. I also tried older versions of Firefox up to version 20, but they failed too.

Is Firefox not compatible with Android 2.3.6 or is there another problem that may cause this? If it is compatible, how can I debug this problem?

I see the question Will Firefox work on my mobile device?. This article mentions the minimum requirements:

Firefox is compatible with Android 2.2 and above devices. Installation requires about 24 MB internal storage, 384 MB of RAM and a display that is at least 320 pixels high and 240 pixels wide.

In my device:

RAM: 768 MB
Android version: 2.3.6
Size:   320 x 480 pixels
  • 1
    One easy way to help confirm if your device is compatible is check the list of devices where @eldarerathis shares link for. Another way is to use googleplaystore which will either show a not compatible warning and not let you install or simply will not show firefox in search results to indicate your device "cannae no dae dat". Firmware version, baseband version and cpu version will have direct impact on what you can or cannot run regardless of Android version. i.e. my device is running 4.0.1 cyangenmod 9 heavily modded ICS but firefox no worky for me. ARM v7 cpu may be needed... – geezanansa Aug 6 '13 at 17:20
  • @geezanansa actually raises a good point. ARMv6 processor support is still labeled as "experimental" according to Mozilla. It's possible that your device's processor is the issue, though you could try side loading a nightly build for ARMv6 if that is the case. What kind of phone is it? – eldarerathis Aug 6 '13 at 18:18
  • There are lots of devices in list which are not ARM V7 even ones older than mine but my device is not on list :¬ ( but i can not work out how to get firefox running on my device so will ask specific question regarding to what @eldarerathis indicates could be doable. – geezanansa Aug 6 '13 at 18:36
  • "Application not installed", this means you tried to install Firefox with a downloaded APK, correct ? – Matthieu Harlé Aug 6 '13 at 19:28
  • 1
    @Shywim I live in IRAN, Google bans Iranian users for Google Play, So I can't use it. I download firefox apk from Mozilla ftp. – Arash Mousavi Aug 7 '13 at 10:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.