Using Heimdall v1.4 RC1 to flash Clockworkmod Recovery on a Samsung S4, I get the following,

$ sudo heimdall flash --RECOVERY ./recovery.img --no-reboot
Heimdall v1.4 RC1

Copyright (c) 2010-2012, Benjamin Dobell, Glass Echidna

This software is provided free of charge. Copying and redistribution is

If you appreciate this software and you would like to support future
development please consider donating:

Initialising connection...
Detecting device...
Claiming interface...
Attempt failed. Detaching driver...
Claiming interface again...
Setting up interface...

Checking if protocol is initialised...
Protocol is not initialised.

Initialising protocol...
Protocol initialisation successful.

Beginning session...
Session begun.

In certain situations this device may take up to 2 minutes to respond.
Please be patient!

Downloading device's PIT file...
PIT file download successful.

Uploading RECOVERY
ERROR: Failed to confirm end of file transfer sequence!
ERROR: RECOVERY upload failed!

Ending session...
Releasing device interface...
Re-attaching kernel driver...

I've even tried two different builds of Clockworkmod,

-rw-rw-r-- 1 ecarroll ecarroll 6.8M Aug 11 23:23 clockworkmod_6.0.3.2_jfltespr.img
-rw-rw-r-- 1 ecarroll ecarroll 6.8M Aug 12 00:02 recovery-clockwork-

$ md5sum *clock*
c95fac4d0e27fcb0c3355f209e62cd9c  clockworkmod_6.0.3.2_jfltespr.img
760cbf5a3b157ab23f49fcf40b46db2f  recovery-clockwork-

2 Answers 2


This is a because of a bug in Heimdall v1.4 RC1 -- the version that shipped with Ubuntu 13.04. What you'll want to do is upgrade Heimdall to version 1.4 final, or the latest version..

That should do it. Run heimdall info | head -n1 to get your current version.

  • 1
    I'm still getting this in heimdall v1.4.1
    – Jonathan
    Commented Jan 21, 2019 at 7:04

I've been struggling with upgrading my Galaxy Tab P1000 from 2.2 Froyo to CyanogenMod 9 using the official documentation from CyanogenMod.

Heimdall always failed with the message ERROR: Failed to confirm end of file transfer sequence! (Final version 1.4 in Windows and Linux).

Unfortunately, Samsung Kies did not want to upgrade firmware to 2.3 Gingerbread. So I desperately tried Odin. And voila - I got 2.3.6 running.

Curious as I am, I tried again with heimdall. This time, heimdall succeeded with installing recovery. :D Unfortunately, I got an error when installing any CM image /dev/block/stl11 and /dev/block/stl10 were unmountable. Something was still wrong.

Finally I found this reference, and it worked well. :)

  • 1
    Thanks for sharing, Torsten! But as a link bears the danger to "expire", could you please edit your answer and include an excerpt – so your answer stays useful even in that case?
    – Izzy
    Commented Oct 2, 2013 at 6:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .