3

I'm doing my first steps with Android. I'm using a Mac, and no Eclipse.

I've installed my first toy application with

adb install bin/*.apk

and verified that it existed in the emulator. Then I made some changes, reran the build, and tried to install again, which brought the error message

   pkg: /data/local/tmp/DefaultActivity-debug.apk

Failure [INSTALL_FAILED_ALREADY_EXISTS]

Fine, so I have to uninstall first. So I tried the following:

adb uninstall DefaultActivity adb uninstall de.rf.DefaultActivity adb uninstall DefaultActivity-debug adb uninstall /data/local/tmp/DefaultActivity-debug.apk adb uninstall de.rf

but all of them just brought the error message "Failure", with no further explanation.

It's not a really big problem, because I can simply restart the emulator and use "adb install ....", but I'm curious: How do I correctly use the "uninstall" command?

My activity looks like this:

package de.rf; ... public class DefaultActivity extends Activity { ... }

6

You don't have to uninstall, when you install an app already installed, you have to use adb install -r. (for more help, juste type adb)

To uninstall an app, you have to use adb uninstall package-name (e.g. adb uninstall com.example.app).

  • Thanks a lot, this works. Strangely I have read through adb -help several times, but somehow always overlooked the (clearly visible) -r switch!!! – user1934428 Aug 14 '13 at 8:56
2

To uninstall the package using adb, you need to use the package name listed in the manifest, for example:

adb uninstall com.shadowburst.showr

You might also want to use the -k option to avoid deleting the app's data when uninstalling.

You can also uninstall apps from the Settings app: click Apps, find your app in the list, then click Uninstall. This works even if the app was installed via adb or directly from an APK file.

By the way, don't use de.rf as a package name, even if you own the internet domain rf.de. You want the package name to be something inside a domain you control, to ensure that it won't clash with another Java package you write (such as another app or a library).

  • Thank you for your suggestions and explanations! Right now I'm just playing around, and I will for sure follow your recommendation and use a more sensible package name when I'm starting to do real work. – user1934428 Aug 14 '13 at 8:52
  • BTW, clicking on "Settings" displays a message box saying "Unsupported Action". Could it be that this is because I'm using an Android SDK which is already a bit outdated (0.9beta)? – user1934428 Aug 14 '13 at 8:55
  • Probably. The early versions of the emulator were a bit rubbish. – Dan Hulme Aug 14 '13 at 10:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.